Redmine shows issues of another project

Added by Fabio Napoleoni over 13 years ago

I recently migrated a Redmine installation from a FreeBSD platform to a Debian machine, and then after the migration I performed an upgrade to Redmine 0.9.4

Now I have the following problem, when broswing issues of project X redmine shows also the issues of project Y, the same thing happen with project Z. The three project are unrelated, and this is not happening with other projects in this installation.

Maybe a db corruption, or some filter setting I don't see.

I checked project identifiers and issues identifiers in db and everything seems fine.

What should I check?

This is the output of the about script:

# RAILS_ENV=production script/about
About your application's environment
Ruby version              1.8.7 (x86_64-linux)
RubyGems version          1.3.4
Rack version              1.0
Rails version             2.3.5
Active Record version     2.3.5
Active Resource version   2.3.5
Action Mailer version     2.3.5
Active Support version    2.3.5
Edge Rails revision       unknown
Application root          /var/rails/redmine-0.9.4
Environment               production
Database adapter          mysql
Database schema version   20100221100219

About your Redmine plugins
Mylyn Connector plugin   2.6.4.stable

Redmine is running on Debian Stable (aka Lenny) under Apache 2.2 web server with mod passenger installed (from backports)

ii  libapache2-mod-passenger   2.2.11debian-1~bpo50+1     Rails and Rack support for Apache2

Replies (1)

RE: Redmine shows issues of another project (SOLVED!!!) - Added by Fabio Napoleoni over 13 years ago

I found the problem, the internal structure of projects table was corrupted (probably a manual edit of some property), i noticed that lft and rgt values are wrong. Since the Project model act as nested set I solved by opening a console and typed (after a full backup):

# RAILS_ENV=production script/console 
Loading production environment (Rails 2.3.5)
>> Project.rebuild!
=> -- new values for my projects as output --
>> quit