ImageMagik - Rmagick problems on Windows

Added by John H almost 8 years ago

Hi all,

Im having problems installing the rmagick gem on windows 7 with ruby1.9.3 and jruby1.7.13 and Redmine2.5.1.

I followed the "How to" tutorial on this site, however it didn't work.
1. I installed ImageMagick
2. I opened cmd and set CPATH and LIBRARY_PATH to the correct destinations
3. I try "gem install rmagick" <- Results in Error: Invalid Drive Specification
4. I try a line similar to this:
"gem install rmagick --platform=ruby -- --with-opt-lib=C:\ImageMagick-6.7.0-Q16\lib --with-opt-include=C:\ImageMagick-6.7.0-Q16\include" <- Results in the same error as #3.

I scowered google and stackoverflow and there are a lot of suggestions, but none have worked.
For instance, they say that rmagick stopped working at ImageMagick6.7.9.9, so I tried installing that, still didnt work.

It seems as if my path has been set and cant be changed, as I point it directly to where it is installed in the "gem install" cmd and it still says "Invalid Drive Specification". Furthermore, all installs of ImageMagick are windows binary, and installed with headers etc.

Attached is a s/s of me setting the paths and trying to install.

Please help.


rmagick.png (31.7 KB)

rmagickFail.png - Added wrong attachment before. (51.8 KB)