I can't receive email when i add the news, please help me.

Added by Dennis Gao almost 11 years ago

i can't receive email when i add the news.

Environments:
Ubuntu 9.10 Server
Redmine v0.8.7 at /opt/redmine
Apache2, set ln -s at /var/www/redmine
PostgreSQL
everything is going ok.

I set the email configuration in email.yml,
i can receive the email when i add users/add forums comments/add issues/update issues.

But when I add the documents, add news, add files, we can not receive the e-mail.
I have checked all the Administration/Settings/Email notifications/
News added = Yes
Document added = Yes
File added = Yes
and restart apache2, I still have not received e-mail.

I have commented the
/opt/redmine/config/environments/production.rb
  1. No email in production log
    #config.action_mailer.logger = nil
    But, i still can not see any email informations in production.log.

so, anyone could help me please? thanks.

Replies (6)

RE: I can't receive email when i add the news, please help me. - Added by Dennis Gao almost 11 years ago

when i query the settings table:

select * from settings where name like '%notif%'

Text
---
- issue_added
- issue_updated
- news_added
- document_added
- message_posted

RE: I can't receive email when i add the news, please help me. - Added by Yuriy Vidineev almost 11 years ago

I have the same problem.
My redmine is svn trunk (r3111) running on Debian Lenny with mongrel.

RE: I can't receive email when i add the news, please help me. - Added by J.K Wang almost 11 years ago

I have the same problem .
I can't receive any mail notification but admin test email.

postgresql 8.3.8

RE: I can't receive email when i add the news, please help me. - Added by Dennis Gao almost 11 years ago

up

please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!
please support this feature, thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks! thanks!

:)

RE: I can't receive email when i add the news, please help me. - Added by J.K Wang almost 11 years ago

I had resolved this problem.

I found if the recipients contains invalid email address, the server will not send the mail.
I deleted invalid mail address, it's OK.

(1-6/6)