Project

General

Profile

Actions

Defect #10278

closed

Related issues field lost after upgrade to 1.3.0

Added by Alexander Reznik over 11 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

After upgrade to Redmine 1.3.0 (from 1.2.1) field "related issues" not shown, if issue already has not any relations.
I double check rights of management issues relations, but no one couldn't add a related issue.


Related issues

Is duplicate of Redmine - Defect #9969: First relation adding is not availableClosed

Actions
Actions #1

Updated by Jean-Philippe Lang over 11 years ago

  • Resolution set to Cant reproduce
Actions #2

Updated by Alexander Reznik over 11 years ago

How can I help to reproduce this bug?
Maybe you need some database dumps to reproduce? In our setup we use a lot of groups with different rights, I think it could affect.

Actions #3

Updated by Jean-Philippe Lang over 11 years ago

Any plugins, custom changes, custom themes... ?

Actions #4

Updated by Tao Lin over 11 years ago

I got the same issue as well. I have follow plugins:

  • Advanced roadmap & milestones plugin
  • Redmine Exception Handler plugin
  • Redmine Light Box plugin
  • Redmine Logs plugin

Before I upgrade, I also use above plugins as well without any problem.

Actions #5

Updated by Tim Brigginshaw over 11 years ago

Exactly the same problem here. Upgraded to 1.3.1, Related Issues section no longer available for those issues which did not previously have them (or for new issues).
Plugins:

redmine_backlogs
redmine_closed_issue
redmine_importer
redmine_spent_time_column

No changes were made when upgrading from 1.2.1.
Running on RHEL 6, Ruby 1.8.7, gems 1.3.6

Actions #6

Updated by Alexander Reznik over 11 years ago

plugins:
Advanced roadmap & milestones plugin
Redmine Default Version plugin
Redmine Wysiwyg Textile - not using, but installed.

Running on Ubuntu 10.04, Mongrel Web Server 1.1.5, Ruby 1.8.7, gems 1.3.7

I've done some source code research and looks like bug is somewhere in access right check.

Actions #7

Updated by S├ębastien Gripon over 11 years ago

I have also a problem with issues relation bu for me, the field is here, the AJAX part seems to work when I enter a number but the OK button does nothing. Maybe it is related with #7688 because in logs, I have this:

Processing IssueRelationsController#new (for 10.38.129.84 at 2012-02-23 12:36:28) [POST]
  Parameters: {"commit"=>"Add", "issue_id"=>"3114", "action"=>"new", "authenticity_token"=>"xxxxxx", "relation"=>{"delay"=>"", "issue_to_id"=>"3028", "relation_type"=>"relates"}, "controller"=>"issue_relations"}
Filter chain halted as [:find_relation] rendered_or_redirected.
Completed in 0ms (View: 0, DB: 0) | 404 Not Found [http://redmine.neopost.grp/issue_relations/new?issue_id=3114]

Nut the good address for me should be:

http://redmine.neopost.grp/redmine/issue_relations

However, mongrel_patch seems to not work any more.

Update: In fact I have version 1.3.0

Actions #8

Updated by Etienne Massip over 11 years ago

  • Status changed from New to Closed
  • Resolution changed from Cant reproduce to Invalid

Duplicate of #9969; this behavior is caused by a plugin.

Actions #9

Updated by Tim Brigginshaw over 11 years ago

OK, works fine now, thanks for the feedback.
For information, the redmine_closed_issue (0.2) plugin caused the error:

The following plugins continue to work fine

redmine_backlogs (0.7)
redmine_importer
redmine_spent_time_column

Actions #10

Updated by Tao Lin over 11 years ago

And after upgrade 'Advanced roadmap & milestones' plugin from 0.4.0 to 0.5.1, my Redmine 1.3.0 also works now.

Thanks, guys!

Actions #11

Updated by Martin G over 11 years ago

Is at this moment the only solution uninstalling the redmine_closed_issue plugin?

Actions #12

Updated by Chris Magowan over 11 years ago

i have installed (nearly) the latest version of Redmine (1.4.0), but i am still missing this "related issues" options. has the fix been released?

Actions

Also available in: Atom PDF