Defect #10779

redmine cannot deal with 4-byte utf-8 characters

Added by flap flap over 9 years ago. Updated about 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Database
Target version:-
Resolution:Duplicate Affected version:1.4.0

Description

When entering an issue description or a note, all text after a 4-byte utf-8 character seems to get truncated.

To reproduce just create a new issue
in the description enter some text and a 4-byte utf-8 such a 🐳 and then some more text.
Then save the issue
All text after the 4-byte utf-8 will be gone from the ticket...

Entering a character using html-entities does work (eg 🐳). Copy-pasting a 4-byte utf-8 char fails. 3-byte utf-8 chars do work.

version/env: whatever demo.redmine.org is running.


Related issues

Related to Redmine - Defect #10772: 4-byte utf-8 characters Closed
Duplicates Redmine - Defect #18866: MySQL: disappear after 4-Byte UTF-8 New

History

#1 Updated by Etienne Massip over 9 years ago

  • Category set to Issues

Related to #10772.

#2 Updated by Etienne Massip over 9 years ago

  • Category changed from Issues to I18n

#3 Updated by Toshi MARUYAMA about 6 years ago

  • Category changed from I18n to Database
  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #18866.

#4 Updated by Toshi MARUYAMA about 6 years ago

  • Duplicates Defect #18866: MySQL: disappear after 4-Byte UTF-8 added

#5 Updated by Toshi MARUYAMA about 6 years ago

  • Duplicates deleted (Defect #18866: MySQL: disappear after 4-Byte UTF-8)

#6 Updated by Toshi MARUYAMA about 6 years ago

  • Duplicates Defect #18866: MySQL: disappear after 4-Byte UTF-8 added

Also available in: Atom PDF