Defect #11489

Redmine is not able to show wiki images properly

Added by Michael Rüegg about 9 years ago. Updated over 8 years ago.

Status:NewStart date:
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Cant reproduce Affected version:

Description

Hi. My redmine installation (Ubuntu 12.04, redmine 1.3.2) is not able to show images on wiki pages properly. Sometimes they show up, and sometimes they do not. My issue seams related to this:

http://www.redmine.org/boards/2/topics/7015

Unfortunately, that was never resolved. It happens with images I have attached to the wiki page, e.g.:

!{width:450px}/attachments/download/2/buildconsole.png!

errlog.txt Magnifier (33 KB) Michael Rüegg, 2012-07-31 09:52

History

#1 Updated by Jean-Philippe Lang about 9 years ago

Sorry but you'll have to be a bit more specific here if you want this issue to be investigated.

#2 Updated by Michael Rüegg about 9 years ago

Jean-Philippe Lang wrote:

Sorry but you'll have to be a bit more specific here if you want this issue to be investigated.

Okay, sorry. Maybe an example helps: The problem described happends on the following redmine instance: http://sconsolidator.com/. As you can see, the two images on the wiki main page sometimes appear, sometimes they do not. Normally, a few page refreshes help. Any idea? Thanks.

#3 Updated by Jean-Philippe Lang about 9 years ago

  • Priority changed from High to Low

Tried a dozen times without problem.

#4 Updated by Jean-Philippe Lang about 9 years ago

  • Resolution set to Cant reproduce

#5 Updated by Michael Rüegg about 9 years ago

What do you mean by "without problem"? Do you always see all the pictures on the following page without the need to reload it?

http://sconsolidator.com/projects/sconsolidator/wiki/Getting_Started

I have a couple of customers which have experienced this issue of not seeing all images at once. It is very inconvenient when you have to say them they should always reload the page a couple of times!

#6 Updated by Jean-Philippe Lang about 9 years ago

Oh i looked at the first one only. I get a lot of 500 errors on images. You need to provide the error stack trace that you'll find in your application.log (see SubmittingBugs).

#7 Updated by Michael Rüegg almost 9 years ago

You're right, I get a lot of 500 errors for certain images, e.g.:

x.x.x.x - - [31/Jul/2012:09:24:19 +0200] "GET /attachments/download/19/dependencyview2.png HTTP/1.1" 500 958 "http://sconsolidator.com/projects/sconsolidator/wiki/Getting_Started" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/12.04 Chromium/18.0.1025.168 Chrome/18.0.1025.168 Safari/535.19"

But this does not happen all the time and not with all images and is hence not deterministic. Any ideas what could cause this 500 errors? Attached I send you the error log with the exceptions.

#8 Updated by Cecilia Dahlgren over 8 years ago

Hello

I experience this problem as well, when I add a image to an issue or to a wiki page using this syntax

i does not show, but it is not always, sometimes it works.

If you create a page it works once and next time if you upload a new image file with the same name it suddenly do not show the image any longer.

Best Regards
Cecilia

Environment:
Redmine version 2.2.3.stable
Ruby version 1.9.3 (x86_64-linux)
Rails version 3.2.12
Environment production
Database adapter Mysql2

#9 Updated by Cecilia Dahlgren over 8 years ago

Hello again,

I think I know when the problem comes, if you have a name with spaces in the image file name it do not work.
Always choose a name that do not contains any spaces.

I had a name "file name.png" when I changed to "file_name.png" it worked again.

Best Regards
Cecilia Dahlgren

#10 Updated by Etienne Massip over 8 years ago

Cecilia Dahlgren wrote:

Hello again,

I think I know when the problem comes, if you have a name with spaces in the image file name it do not work.
Always choose a name that do not contains any spaces.

I had a name "file name.png" when I changed to "file_name.png" it worked again.

Best Regards
Cecilia Dahlgren

You can upload the file with space in name but you have to use underscore in place in !my_image! image tag.

Also available in: Atom PDF