Defect #11717

Repository links: Spaces and multiple repositories don't mix.

Added by Thomas Themel over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution:Invalid Affected version:1.4.1

Description

This may or may not be a bug depending on the precise specification, but I suppose it should work... When using Redmine links, I can either
  • link to a file in a non-primary repository using source:myrepository|/path/to/file
    or
  • link to a file with spaces using source:"path/with spaces/to file.txt"

It would appear logical that these two could be combined to form a link to a file with spaces in a non-primary respository using source:myrepository|"path/with spaces/to file.txt", but that is not recognized as a Redmine link (or at least, recognized only up to the | character). I suspect that the problem is with the giant regexp in parse_redmine_links in `application_helper.rb`, but it is a little too intimidating for me to wade in there and attempt a fix myself.

redmine-about.txt Magnifier - scripts/about output (671 Bytes) Thomas Themel, 2012-08-27 16:03

History

#1 Updated by Etienne Massip over 9 years ago

source:"myrepository|/path/with spaces/to file.txt" works on trunk, did you try it?

#2 Updated by Thomas Themel over 9 years ago

  • Status changed from New to Resolved

Thanks, that did it!

#3 Updated by Etienne Massip over 9 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Invalid

Also available in: Atom PDF