Defect #12045

Reordering of Enumerations broken

Added by Jakes vdM over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Invalid Affected version:2.1.2

Description

New installation on Ubuntu 12.04 LTS 64-bit - current stable all-round

Environment:
Redmine version 2.1.2.stable
Ruby version 1.8.7 (x86_64-linux)
Rails version 3.2.8
Environment production
Database adapter Mysql2
Redmine plugins:
no plugin installed

Created new Enumerations for Activities (time tracking), OK, but when I try to reorder any items I get a 404 (https://jobs/enumerations/10?enumeration%5Bmove_to%5D=highest):
The page you were trying to access doesn't exist or has been removed.

Think that's all information required - please let me know if anything else is needed

History

#1 Updated by Jean-Philippe Lang over 9 years ago

  • Resolution set to Cant reproduce

Works fine for me:

[19:11:56,751] POST http://localhost:3000/enumerations/9?enumeration%5Bmove_to%5D=highest [HTTP/1.1 302 Found  156ms]

#2 Updated by Jakes vdM over 9 years ago

Thanks for looking into this.

I'm new to RedMine & have little to no experience/knowledge with Ruby/RoR.
How can I go about debugging this issue & providing additional information?

#3 Updated by Jakes vdM over 9 years ago

  • Status changed from New to Resolved

UPDATE: hmmmm :/ seems OK now from a different client machine - nothing has changed server-side overnight.
I'll tentatively mark this closed & revisit the issue if it crops up again.

Thanks for the help

#4 Updated by Jean-Philippe Lang over 9 years ago

Make sure that javascript is enabled, it won't work if it's not.

#5 Updated by Etienne Massip over 9 years ago

  • Status changed from Resolved to Closed
  • Resolution changed from Cant reproduce to Invalid

Also available in: Atom PDF