Defect #12334

Wiki export to PDF broken format

Added by Long Nguyen Hai about 9 years ago. Updated about 9 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Long Nguyen Hai% Done:

10%

Category:PDF export
Target version:-
Resolution:Duplicate Affected version:2.0.2

Description

When exporting ticket to PDF,
Some national characters are broken. Probably bad support for UTF-8 or maybe PDF convertor doesn't use appropriate font with full UTF-8 support.
Most of hyperlinks are disabled , so we couldn’t view relevant documents.
A unexpected column is added in left.

Information:
- ruby 1.9.3p194
- Rails 3.2.5
- rubygem 1.8.24
- Redmine 2.0.2

Redmine.PNG - Tables in Wiki (64.5 KB) Long Nguyen Hai, 2012-11-09 06:45

Redmine_pdf.PNG - Tables in PDF (112 KB) Long Nguyen Hai, 2012-11-09 06:47

Table_of_content.png - Not show "Tables of content" (93.4 KB) Long Nguyen Hai, 2012-11-09 06:47

Redmine_Wiki.PNG - Format in Wiki (37.6 KB) Long Nguyen Hai, 2012-11-12 04:35

Redmine_PDF.PNG - Format wrong PDF (55.9 KB) Long Nguyen Hai, 2012-11-12 04:35


Related issues

Related to Redmine - Defect #11927: Vietnamese Unicode charater broken when exporting to PDF Closed

History

#2 Updated by Jun NAITOH about 9 years ago

Please see #10688 and #9842.

#3 Updated by Toshi MARUYAMA about 9 years ago

  • Status changed from New to Closed
  • Resolution deleted (Cant reproduce)

Long Nguyen Hai wrote:

Some national characters are broken. Probably bad support for UTF-8 or maybe PDF convertor doesn't use appropriate font with full UTF-8 support.

Attachment PDF seems Vietnamese.
See #11927.

#4 Updated by Toshi MARUYAMA about 9 years ago

  • Resolution set to Duplicate

#5 Updated by Long Nguyen Hai about 9 years ago

Thanks for help!

I have just fix some bug, But Wiki export something wrong: Document link, Column
Format in Wiki
Format wrong PDF

#6 Updated by Long Nguyen Hai about 9 years ago

  • Status changed from Closed to Reopened

#7 Updated by Toshi MARUYAMA about 9 years ago

  • Status changed from Reopened to Closed
  • Resolution changed from Duplicate to Cant reproduce

I cannot reproduce.
If you have note-5 bug without any plugins,
please create new issue.
This issues has many matters.

#8 Updated by Toshi MARUYAMA about 9 years ago

And please update Redmine to 2.0.4 or 2.1.2.
2.0.2 has defect #10688.

#9 Updated by Toshi MARUYAMA about 9 years ago

  • Resolution changed from Cant reproduce to Duplicate

Also available in: Atom PDF