Defect #12397

Error in Textile conversion of HTTP links, containing russian letters

Added by Albert Shakirov over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:Jean-Philippe Lang% Done:


Category:Text formatting
Target version:2.2.0
Resolution:Fixed Affected version:2.1.2


I've just upgraded to the latest Redmine version and got this error:
when I try to write links using "Title":URL notation and I use russian letters in the URL part, my links become broken.
The same error I've got on your page.

Let's try it right here:
in Russian:

in English:

Redmine version 2.1.2.stable
Ruby version 1.9.3 (i686-linux)
Rails version 3.2.8

Related issues

Related to Redmine - Patch #12077: Links ending with non-english letters don't parse completely Closed

Associated revisions

Revision 10879
Added by Jean-Philippe Lang over 9 years ago

Fixed that autolinks and textile links ending with cyrilic characters are broken (#12397).


#1 Updated by Albert Shakirov over 9 years ago

Yes! The same error is on your site.
In Redmine 1.4 version everything was OK.
Again, the problem in the links like this (in this example I'm going to put some spaces to prevent it to convert to URL link with title):
"ТЕСТ" : http :// / Тест

#2 Updated by fangzheng (方正) over 9 years ago

By the way, when I add some english chars at the end of the url, it works fine. see below:тесттесттестABCтестABCтест123тест123


So add a "/" at the end could be a workaround.

#3 Updated by Albert Shakirov over 9 years ago

Yes, I know that. I've done a lot of experiments. The error appears when the LAST LETTER in the URL is Russian letter.
Unfortunatly, adding a slash to the end is not an option for me. My links refer to wiki pages (to another site, not Redmine wiki), so URL with a "/" at the end isn't correct.

#4 Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.2.0
  • Resolution set to Fixed

It's fixed in r10879 with tests. Only works with ruby1.9.

Also available in: Atom PDF