Feature #14018

Allow tracker field appear empty on new issues' creation (force user to choose tracker)

Added by Bruno Medeiros over 7 years ago. Updated over 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate

Description

When creating new issues on Redmine, the default tracker appears already selected on the tracker selection box when a user clicks on 'New Issue'. It's bad because it encourages users to stick with the default tracker instead of think about the right tracker to the issue being created.

I suggest a option on configuration page to make the tracker selection box appear empty, still mandatory, forcing the user to think about the right tracker and pick up it.


Related issues

Duplicates Redmine - Feature #1365: Allow Project by Project setting of a 'Default' Tracker v... New 2008-06-03

History

#1 Updated by Michael Wahnon over 7 years ago

+1 on this. I'm looking for ways to more effectively separate bugs and features for data collection purposes, and this is challenging when users can simply file with a default tracker. The best solution is to force them to choose the correct tracker at issue creation, which is currently impossible.

It is important to consider that if Tracker is configured to default to blank, when the Tracker field is left at the default blank, the issue should not save forcing the user to select a Tracker from the list.

#2 Updated by Manuel Mai over 5 years ago

+1!
Someone meanwhile has a solution on this?
thanks, Manuel

#3 Updated by Boerje Ulrich over 4 years ago

Hi there,

definately a must have, I´m tired of changing the tracker of about 40% of all tickets.

#4 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #1365.

#5 Updated by Toshi MARUYAMA over 4 years ago

  • Duplicates Feature #1365: Allow Project by Project setting of a 'Default' Tracker value including nil added

Also available in: Atom PDF