Project

General

Profile

Actions

Defect #15204

closed

Git commit message not formatted at all in <project>/repository/revisions/<SHA> view

Added by T K almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
SCM
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

The commit message of a Git commit is not formatted at all when displaying a single commit in projects/<PROJECTID>/repository/revisions/<SHA>. Usually, a Git commit has a short title separated with an empty line from a detailed description. Though this gets correctly written to the rendered HTML, empty lines in an HTML document are not rendered.

The commit message

an awesome commit

This commit finally fixes those annoying bugs and made this piece of
software an awesome product!

Is displayed in a single line

an awesome commit This commit finally fixes those annoying bugs and made this piece of software an awesome product!

I would at least expect the empty line to be visible. In addition, it would be helpful when the commit title can be styled differently, e.g. bold.


Related issues

Is duplicate of Redmine - Defect #11040: Git commit messages have strange formatting:New

Actions
Actions #1

Updated by Toshi MARUYAMA almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate with #11040.

Actions #2

Updated by Toshi MARUYAMA almost 10 years ago

  • Is duplicate of Defect #11040: Git commit messages have strange formatting: added
Actions

Also available in: Atom PDF