Defect #16076

Wrong custom fields are displayed / weird behavior when selecting different projects on issue edit form

Added by Marvin Hohlfeld almost 8 years ago. Updated almost 8 years ago.

Status:Needs feedbackStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Custom fields
Target version:-
Resolution:Cant reproduce Affected version:2.4.1

Description

Let's say we have three Projects:

Project A with TrackerA with Custom Fields F1 and F2
Project B with TrackerB with Custom Field F1 and F2
Project C with TrackerC with Custom Field F3

...and a ticket created in Project A (with F1 and F2 filled)

If we now >Edit< this ticket to move it to another Project and play with the project dropdown to trigger the ajax form update:

(in this order:)

1. Select Project C: No custom fields are shown (expected: display of F3 with no value)
2. Select Project A: Default fields are shown but no custom fields! (expected: original display with F1 and F2 and thei original values)
3. Select Project B: All correct again !?, F1 and F2 are displayed with their original values
4. Select Project A again: All correct

This is reproducable at every time. I think there is some issue with the ajax form update, when try to choose between projects with different trackers and custom fields?

redmine-customField-issue.png (79.7 KB) Marvin Hohlfeld, 2014-02-25 08:53

History

#1 Updated by Jean-Philippe Lang almost 8 years ago

  • Status changed from New to Needs feedback
  • Resolution set to Cant reproduce

This scenario works for me. Does project C have the same trackers than project A and B?

#2 Updated by Marvin Hohlfeld almost 8 years ago

Yes, all projects have different trackers (which shares some custom fields and some not)

I have attached screenshots to show the issue. The first form is only to show the expected output, when changing the project in the second form from B to A. (just selected another project without any saving!)

Also available in: Atom PDF