Defect #16132

Unable to complete db migration task in update to r12244

Added by James Byrne over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Resolution:Invalid Affected version:2.4.3



svn info
Path: .
Repository Root:
Repository UUID: e93f8b46-1217-0410-a6f0-8f06a7374b81
Revision: 12244
Node Kind: directory
Schedule: normal
Last Changed Author: tmaruyama
Last Changed Rev: 12243
Last Changed Date: 2013-10-29 02:24:28 -0400 (Tue, 29 Oct 2013)

In the process of upgrading from r11085 using svn update and subsequent to running bundle update in the application root directory I see the following when I run the rake db:migrate task:

[redmine]# bundle exec rake db:migrate RAILS_ENV=production
rake aborted!
no such file to load -- rack/cache/context
/var/data/pas-redmine/rails/ruby/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'


#1 Updated by Toshi MARUYAMA over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

James Byrne wrote:

/var/data/pas-redmine/rails/ruby/1.8/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in `require'

2.4.3 uses Rails 3.2.16.
You need to run "bundle update".

#2 Updated by James Byrne over 7 years ago

  • Status changed from Closed to Reopened

As is clearly stated in my original report this problem occurs AFTER I ran bundle update. Do you have another suggestion?

#3 Updated by Toshi MARUYAMA over 7 years ago

  • Status changed from Reopened to Closed

Please use forum for such question.
We cannot support individual environment problem.
Please create issue if you are sure it is Redmine core defect.

Also available in: Atom PDF