Defect #1795

Automatic repository creation Reposman.rb

Added by Jonathan Dray over 13 years ago. Updated over 13 years ago.

Status:ClosedStart date:2008-08-17
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Invalid Affected version:

Description

Hi all,

I upgraded my redmine installation using svn and I now get an error with the automatic repository creation script.
The revision number is : 1747

I am running the script with the following arguments :
ruby /usr/local/share/redmine/extra/svn/reposman.rb --quiet --redmine https://www.mysite.com/ --svn-dir /var/svn --owner www-data --url https://my.site.com/svn-private/

And get the error message :
/usr/lib/ruby/1.8/soap/streamHandler.rb:200:in `send_post': 302: Found (SOAP::HTTPStreamError)
from /usr/lib/ruby/1.8/soap/streamHandler.rb:109:in `send'
from /usr/lib/ruby/1.8/soap/rpc/proxy.rb:170:in `route'
from /usr/lib/ruby/1.8/soap/rpc/proxy.rb:141:in `call'
from /usr/lib/ruby/1.8/soap/rpc/driver.rb:178:in `call'
from (eval):6:in `projects'
from /usr/lib/ruby/1.8/soap/wsdlDriver.rb:117:in `__send__'
from /usr/lib/ruby/1.8/soap/wsdlDriver.rb:117:in `Projects'
from /usr/local/share/redmine/extra/svn/reposman.rb:136

Did anyone experienced the same issue ?
Thank you
Regards,
Jonathan Dray

History

#1 Updated by Jean-Philippe Lang over 13 years ago

I'm not able to reproduce this problem with latest trunk.
Could you give your rails version and post the application log (on the redmine side with log level set to debug if possible) that is generated when running reposman.rb. Thanks.

#2 Updated by Jonathan Dray over 13 years ago

Hi Jean-Philippe,

After switching the application log level to debug and examinating production log file in details, I found the problem was not with redmine but with apache proxy configuration.
I use apache2 as a proxy to the thin webserver (monitored with god). Apache proxy is enabled with https protocol and listens on https://www.mysite.com/ and requests are redirected to http://localhost:3000/ on thin webserver.

I called the reposman.rb script on the https address.
Executing reposman with redmine option pointing to thin local address works perfectly.

Thanks for you help.
You can close this ticket

Regards,
Jonathan Dray

#3 Updated by Jean-Philippe Lang over 13 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Good news :-) Thanks for the feedback.

Also available in: Atom PDF