Defect #1836

Redmine doesn't start if rubyforge > 0.4.5 installed

Added by Alex Dmitriev almost 12 years ago. Updated almost 12 years ago.

Status:ClosedStart date:2008-09-01
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:

Description

I'm trying to run database migrations for Redmine r1778 and receive the following error:

can't activate rubyforge (= 0.4.5, runtime), already activated rubyforge-1.0.0 (Gem::Exception)

I use Ruby 1.8.6, Rails 2.1.0, and gem rubyforge-1.0.0 installed.

Trace log is attached

trace.log - Error trace (7.17 KB) Alex Dmitriev, 2008-09-01 09:54

History

#1 Updated by Aleksei Gusev almost 12 years ago

It looks like a problem is in vendor/plugins/actionwebservice. I have tried to replace it with new version and rake db:migrate works fine.

#2 Updated by Jean-Philippe Lang almost 12 years ago

I don't have this problem with rubyforge-1.0.0 installed.
Could you point to the new version of actionwebservice that solves your problem please ?

#3 Updated by Aleksei Gusev almost 12 years ago

The version of actionwebservice is 1.2.6.

#4 Updated by Aleksei Gusev almost 12 years ago

Ooops... This fixes at least for me by removing rubyforge-0.4.4 gem which was installed in ~/.rubygems. So, I think the bug appears when both versions of rubyforge is installed.

#5 Updated by Jean-Philippe Lang almost 12 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

OK, thanks for the feedback. I close since it doesn't seem to be related with Redmine.

Also available in: Atom PDF