Patch #23977

Redmine performance issues.

Added by bilel kedidi almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Performance
Target version:-

Description

Hello,
We have redmine with 500 projects, and if one user non admin try to load a page it will get rendered in 4-5sec
An admin render the same page in 1 - 1.5 sec
This is a huge difference.
I have made some investigation it is caused by project#allowed_conditions
I have try to make some indexing on projects, trying to improve performance but with the same result
I found that project table is called multiple times so if we can find a better solution
I have made a plugin but need but still having no good result)
https://github.com/bilel-kedidi/redmine_performance

Thanks for helping

History

#1 Updated by Toshi MARUYAMA almost 4 years ago

  • Status changed from New to Closed

Please use more descriptive subject and use forum for question.

Also available in: Atom PDF