Project

General

Profile

Actions

Feature #3200

closed

Wiki Page Categories

Added by Sven Schwyn almost 15 years ago. Updated almost 15 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Wiki
Target version:
-
Start date:
2009-04-18
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

While parent/child relations offer a way back from the child to the parent, it's not very flexible. Page categories could help further organize larger wikis. Example: Wikipedia. This is how it could fit in:

To add a wiki page to one or more categories, add the following line somewhere on the page:

category: Hardware, Services, Help

This will actually render a box containing the list of categories linking to the respective category index page. To add the page to categories without rendering this box, wrap it in curly brackets:

{category: Hardware, Services, Help}

Category index pages are automatically rendered and contain an alphabetical list of all pages from a given page category. To link to a category page, add the following to a wiki page:

[[category:Hardware]]
[[category:Hardware|Pages related to hardware]]

Or to index pages of another project:

[[sandbox:category:Hardware]]
[[sandbox:category:Hardware|Pages related to hardware]]

Related issues

Is duplicate of Redmine - Feature #480: Wiki: Support categories tagging and autolistingNew

Actions
Actions #1

Updated by Sven Schwyn almost 15 years ago

Maybe a more concise syntax:

Visible category box:

{{category(Hardware, Services, Help)}}

Invisible category assignments (if needed at all):

{{-category(Hardware, Services, Help)}}

Actions #2

Updated by Anonymous almost 15 years ago

+1
also a new 'special' page listing all categories

Actions #3

Updated by Sven Schwyn almost 15 years ago

I've started implementing this and it's surprisingly easy to do. Stay tuned, I'll post a patch shortly. (Including the special page mentioned in the previous comment.)

Actions #4

Updated by Jean-Philippe Lang almost 15 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate
Actions

Also available in: Atom PDF