Defect #33291

Gantt conversion to png failed with error w.r.t. font 'helvetica'

Added by Liane Hampe about 1 year ago. Updated about 1 year ago.

Status:ResolvedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Gantt
Target version:-
Resolution: Affected version:4.1.1

Description

Expected Behavior

Gantt-Diagramm converts to png file format.

Actual Behavior

Clicking on the png link at the bottom of the Gantt page causes an error.

Essentials of Error Message

MiniMagick::Error in GanttsController#show
`.../tmp/mini_magick20200415-1-ufk9mt.png` failed with error: convert-im6.q16: unable to read font `helvetica' error/annotate.c/RenderFreetype/1333. convert-im6.q16: non-conforming drawing primitive definition `text' error/draw.c/RenderMVGContent/4301.

See the two attached sreenshots of the very long error message.

Steps for Reproduction

  1. Install Redmine according to the Technical Details below with a database populated only be Redmines default data
  2. Define a Project by only setting a name
  3. Create a Ticket by only setting name and due date
  4. Go to Gantt page and click the png link at the bottom

Technical Details

Redmine 4.1.1.stable
Default administrator account changed
Attachments directory writable
Plugin assets directory writable (./public/plugin_assets)
MiniMagick available (optional)
ImageMagick convert available (optional)
ImageMagick PDF support available (optional)

Environment:
Redmine version 4.1.1.stable
Ruby version 2.5.8-p224 (2020-03-31) [x86_64-linux]
Rails version 5.2.4.2
Environment development
Database adapter Mysql2
Mailer queue ActiveJob::QueueAdapters::AsyncAdapter
Mailer delivery smtp
SCM:
Subversion 1.10.4
Mercurial 4.8.2
Git 2.20.1
Filesystem
Redmine plugins:
no plugin installed

Screenshot_2020-04-15 Action Controller Exception caught(1).png - Second part of error message (161 KB) Liane Hampe, 2020-04-15 11:04

Screenshot_2020-04-15 Action Controller Exception caught.png - First part of error message (444 KB) Liane Hampe, 2020-04-15 11:04

History

#1 Updated by Liane Hampe about 1 year ago

  • Status changed from New to Resolved

Solution

Installation of gsfonts since it is needed by ghostscript.

This bunch of software is necessary to use the Redmine features accompanied with MiniMagick:

  • ghostscript
  • gsfonts
  • imagemagick

Also available in: Atom PDF