Defect #35680

Error while using local hashes gitlab-repository

Added by Markus Boremski over 1 year ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Resolution: Affected version:


In our company we have many small projects with files in a git-repo.

We wanted to get rid of this crontab-solution: HowTo: Easily integrate a (SSH secured) GIT repository into redmine
Also we never even tried the plugin redmine_git_remote because it doessnt seems to be maintained anymore.

So we set up a single VM running gitlab and redmine side by side.
This setup was choosen to keep usage of git repositories in redmine easy.
We planned to use the local repo-storage of gitlab directly in redmine.

Now, everything is set up, we see the following issue:
  • Set up a repository in redmine and use the local path of the gitlab-repo:
    e.g.: /var/opt/gitlab/git-data/repositories/@hashed/7a/df/3ada92f28b4ceda38562ebf047c6ff0xxxxxxxxxxxxxxxxxxxxxxxx.git
  • calling the repo leads to a 404-error
  • production.log says:
    Started GET "/projects/our_project_id/repository/test_local" for xx.xx.xx.xx at 2021-08-04 09:30:19 +0200
    Processing by RepositoriesController#show as HTML
      Parameters: {"id"=>"our_project_id", "repository_id"=>"test_local"}
      Current user: boremski (id=xx)
      Rendering common/error.html.erb within layouts/base
      Rendered common/error.html.erb within layouts/base (1.0ms)
      Rendering inline template
      Rendered inline template (0.8ms)
      Rendered plugins/redmine_tags/app/views/tags/_header_assets.html.erb (0.4ms)
      Rendered plugins/additionals/app/views/additionals/_html_head.html.slim (0.6ms)
      Rendered plugins/additionals/app/views/additionals/_body_top.slim (0.2ms)
      Rendered plugins/redmine_local_avatars/app/views/hooks/redmine_local_avatars/_base_body_bottom.erb (0.3ms)
      Rendered plugins/time_logger/app/views/time_loggers/_embed_menu.html.erb (18.9ms)
      Rendered plugins/time_logger/app/views/time_loggers/_update_menu.html.erb (20.0ms) [cache hit]
      Rendered plugins/additionals/app/views/additionals/_body_bottom.html.slim (0.3ms)
    Completed 404 Not Found in 156ms (Views: 134.0ms | ActiveRecord: 10.3ms)
Further information:
  • redmine runs as root on our system
    So I dont think this might eb an issue with access-rights.
    To verify I changed the ownder of the repo-folder recursively.
    No change.
  • I also tried to use a soft-link to this folder.
    also no change.

Maybe there is an issue with the @ in the path?


  Redmine version                4.1.2.stable.20855
  Ruby version                   2.5.5-p157 (2019-03-15) [x86_64-linux-gnu]
  Rails version        
  Environment                    production
  Database adapter               Mysql2
  Mailer queue                   ActiveJob::QueueAdapters::AsyncAdapter
  Mailer delivery                smtp
  Subversion                     1.10.4
  Git                            2.20.1
Redmine plugins:
  additionals                    3.0.2-master
  msproject_import               0.6
  redmine_issue_evm              5.5.1
  redmine_mail_from              2.0.0
  redmine_subtask_list_accordion 2.2.0
  redmine_tags                   4.0.0
  redmine_workload               1.1.0
  time_logger                    0.5.4

Also available in: Atom PDF