Defect #4287

Textile table not working when missing newline after last row

Added by Henrik Ammer about 13 years ago. Updated about 13 years ago.

Status:ClosedStart date:2009-11-25
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Resolution:Invalid Affected version:


I tried the following textile in a wikipage:

|_. Test|_. Test2|
|Testing|And yet another test|

When there is no newline after the last row of the textile table the preview of the wiki shows the contents correctly but when I save the wikipage the whole table just outputs as raw Textile format. I tried it on the demo site but there it worked.
Ofcourse, if there is a newline at the end, it shows up as it should. might be a miss on our behalf but all our updates we've done have not produced any errors so it should not have missed anything.

  • Apache 2.2.12
  • MySQL 5.1.37
  • Ruby 1.8.7
  • Rails 2.3.4
  • Redmine r3092

Nothing in the production.log states an error on the save of the wiki.

My guess is that this might be at an ultralow priority and that's fine by me. :)


#1 Updated by Henrik Ammer about 13 years ago

I saw this in the forum (I wonder why I didn't find that page when I searched the site) regarding table errors,, and tested without the Wiki Extension plugin on it worked as it should.

So it can be closed since it's not Redmine but the plugin that messes up the Textile.

Sorry for the bug that was no bug.

#2 Updated by Jean-Philippe Lang about 13 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Also available in: Atom PDF