Feature #4560

filter update for theme field

Added by Maxim Nikolaevich almost 12 years ago. Updated almost 10 years ago.

Status:ClosedStart date:2010-01-13
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate

Description

It's required to filter tasks which contain several words in various order and placement.


Related issues

Duplicates Redmine - Feature #1140: Filtering using more than one instance of each field New 2008-04-29

History

#1 Updated by Jean-Philippe Lang almost 12 years ago

  • Tracker changed from Defect to Feature

#2 Updated by Maxim Nikolaevich almost 10 years ago

Please rename the issue:
Allow to use one field in filters multiple times
I don't have permission for that

I think it's more common issue and can be resolved in another way.
Need to allow to filter one field several times.
For example:
filtering field "date" type

Now possible values are:

is less than
is more than
in
today
this week
less than days ago
more than days ago
days ago

It's not easy.
more easy values are:

is less than
is more than
less than days ago
more than days ago

But allow to filter this field two times.
For example to get "today" variant i need two filters:

less than days ago = 0
more than days ago = 0

to get "this week" field i need two filters:

less than days ago = 0
more than days ago = 7

Of corse it allow to find issues with two words in the subject: for example date & filter

I can write patch if you are agree to insert this feature in the redmine

#3 Updated by Maxim Nikolaevich almost 10 years ago

i tried last trunk and think date field become more complixity. It's bad, but it's your way. Ok, but the part of this issue still need to be resolved so it can be renamed to "Allow to filter several words in various order and placement in subject."

#4 Updated by Maxim Nikolaevich almost 10 years ago

  • Status changed from New to Resolved

since renaming issue to "Allow to filter several words in various order and placement in subject." it can be marked as duplicate of #1140

#5 Updated by Etienne Massip almost 10 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF