Defect #8697

Error: "NoMethodError: private method `split' called for nil:NilClass" after update from 1.1.3 to 1.2.0

Added by Defferrari Suporte Suporte about 10 years ago. Updated about 10 years ago.

Status:ClosedStart date:2011-06-27
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:

Description

I performed the upgrade from version 1.1.3 to version 1.2.0. After starting the application, the errors appear in the log:

Mon Jun 27 15:57:45 -0300 2011: Error calling Dispatcher.dispatch #<NoMethodError: private method `split' called for nil:NilClass>
/opt/rails/redmine-1.2.0/vendor/rails/actionpack/lib/action_controller/cgi_process.rb:52:in `dispatch_cgi'
/opt/rails/redmine-1.2.0/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:101:in `dispatch_cgi'
/opt/rails/redmine-1.2.0/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:27:in `dispatch'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:76:in `process'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:74:in `synchronize'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/rails.rb:74:in `process'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:159:in `process_client'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:158:in `each'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:158:in `process_client'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in `initialize'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in `new'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:285:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:268:in `initialize'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:268:in `new'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel.rb:268:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:282:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:281:in `each'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/configurator.rb:281:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:128:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/command.rb:212:in `run'
/usr/lib64/ruby/gems/1.8/gems/mongrel-1.1.5/bin/mongrel_rails:281
/usr/bin/mongrel_rails:19:in `load'
/usr/bin/mongrel_rails:19


Related issues

Duplicated by Redmine - Defect #9620: error after updating to the last Redmine trunk: NoMethodE... Closed 2011-11-21

History

#1 Updated by Etienne Massip about 10 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Mongrel 1.1.5 + Redmine 1.2.0 requires patching, see RedmineInstall.

Also available in: Atom PDF