Defect #9205

Affected version not shown in subproject

Added by Gregor Zupan almost 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:2011-09-08
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Invalid Affected version:1.2.1

Description

Hi,

We have a project A and subprojects a,b,c,d.

We define versions in project A and share them with subprojects or all projects.

When we want to open issue in e.g. subproject a we can select target version, but affected version is empty.

Any clue?

Version:
Redmine 1.2.1.stable (MySQL)

brg

01_project_structure-list_of_subprojects.png (13.1 KB) Vili Kosednar, 2011-09-08 12:57

02_parent_project_versions.png (16.5 KB) Vili Kosednar, 2011-09-08 12:57

03_inherited_versions_from_the_parent_project.png (17.3 KB) Vili Kosednar, 2011-09-08 12:57

04_custom_field_empty-should_contain_inherited_versions.png (18 KB) Vili Kosednar, 2011-09-08 12:57

05_Target_version_field_contains_inherited_versions.png (18.6 KB) Vili Kosednar, 2011-09-08 12:57

History

#1 Updated by Etienne Massip almost 9 years ago

  • Status changed from New to Closed
  • Resolution set to Invalid

There is no "Affected version" field in Redmine core, please post your question in Help or Plugins forum.

#2 Updated by Vili Kosednar almost 9 years ago

  • Status changed from Closed to Reopened

Hi - actually the "Affected version" is a custom field of type version.

The problem is that in a sub-project the custom field of type version does not show the inherited versions. In the versions tab of a sub-project you can see all inherited versions, but the drop down list of the custom field is not populated with those values.

Please see the attached screenshots.

#4 Updated by Etienne Massip almost 9 years ago

  • Status changed from Reopened to Closed

In this case this is dup of #8483.

Also available in: Atom PDF