Project

General

Profile

Actions

Feature #9280

closed

Required Custom field on Status

Added by Alex Guillebot over 11 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Custom fields
Target version:
-
Start date:
2011-09-19
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Like in Trac or Jira, i would like that the user precise the "resolution" of an issue when he wants to select the status "Resolved"
I would like that this field is enforce as requiered for this specific workflow status.

So basically, what i would like is that:
  • when creating a custom field
    • and clicking on the the check box "required "
      • A list of Status is displays (including ANY)
      • the user can select as many he needs.
  • and then, every time the ticket changes its status, the ticket tracker checks if one field is not mandatory for this very specific transition.

An alternative ofc, would be to make invisible a custom field for selected workflow status. that would be sweet too.

that would really be awesome and really help to avoid mistakes during the workflow.

thanks


Related issues

Is duplicate of Redmine - Feature #2500: configure custom fields as "required for status transition"Closed2009-01-13

Actions
Actions #1

Updated by S├ębastien Gripon over 11 years ago

+1

Probably duplicated of #2500.

Actions #2

Updated by Etienne Massip over 11 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Indeed, thanks.

Actions

Also available in: Atom PDF