Defect #9788

Revisions not linkified in email notifications anymore

Added by Bruno Medeiros over 10 years ago. Updated over 9 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Email notifications
Target version:-
Resolution:Cant reproduce Affected version:

Description

I recently upgraded Redmine to version 1.3 and realized that the notification emails containing review links are not linkified anymore in the email body. If you enter in the issue on Redmine the link is ok.

I was using Redmine 1.1.3 and all notification emails had linkified review links.

This is not a big deal, but it's a regression, so I'm reporting.

review-with-link.txt Magnifier - linkified review (6.67 KB) Bruno Medeiros, 2012-10-04 23:47

review-without-link.txt Magnifier - not linkified review (6.42 KB) Bruno Medeiros, 2012-10-04 23:47

History

#1 Updated by Etienne Massip over 10 years ago

  • Category set to Email notifications

Thanks for that.

#2 Updated by Jean-Philippe Lang over 10 years ago

What are review links exactly?

#3 Updated by Bruno Medeiros over 10 years ago

The email notification when we have a review link, something like that (don't know the message in english):

Aplicado no changeset r38213.

The 'r38213' was linkified in previous version of Redmine, but it appears as plain text now.

#4 Updated by Etienne Massip over 10 years ago

  • Resolution set to Cant reproduce

I'm not able to reproduce in any way, do you have plugins installed?

#5 Updated by Bruno Medeiros over 10 years ago

No plugins...

I needed to re-add a repository to a project today (I changed the svn folder) and, after re-add, for this project, commits are sent linkified again. For all other projects whose repositories I added before I did the update I still have this bug, no linkified reviews.

I can reproduce it at any time on my production environment. I can provide you logs and even a login on my system (in a sandbox project), just contact me by email if you want.

#6 Updated by Bruno Medeiros over 9 years ago

I've been observing this issue for a long time, and I couldn't notice any pattern. The problem seems to occur randomly.

I've just received two ticket updates, from the same user, on the same project, and one was linkified an the other wasn't. Follow the two email originals, only with some obfuscated info.

The important parts:

linkified:

<p>Aplicado no changeset <a href=3D"http://projetos.company.com.br/projec=
ts/vsg-jv-util/repository/revisions/45988" class=3D"changeset" title=3D"G=
era=C3=A7=C3=A3o Din=C3=A2mica de classes fixes #16588 @1h">r45988</a>.</=
p>

not linkified:

<p>Aplicado no changeset r45987.</p>

Is there any chance of the email is being sent before the review was inserted on the database? It's the only way I can imagine to produce this bug.

#7 Updated by Jean-Philippe Lang over 9 years ago

Bruno Medeiros wrote:

Is there any chance of the email is being sent before the review was inserted on the database? It's the only way I can imagine to produce this bug.

The issue is updated (and the notification sent) in a changeset's after_create callback, so the commit is already inserted in the database, but not yet committed. How is your email delivery configured ?

#8 Updated by Bruno Medeiros over 9 years ago

It's using async method. Here follows my configuration:

# default configuration options for all environments
default:
  # Outgoing emails configuration (see examples above)
  email_delivery:
    delivery_method: :async_smtp
    async_smtp_settings:
      tls: false
      openssl_verify_mode: 'none'
      address: locapop.domain.com.br
      port: 25
      domain: domain.com.br
      authentication: :plain
      user_name: gestorproj@domain.com.br
      password: **********

Also available in: Atom PDF