Defect #9822

ActionView::TemplateError (No route matches {:controller=>"rb_all_projects", :action=>"server_variables"})

Added by Valery Komarov almost 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Resolution:Duplicate Affected version:

Description

on last trunk revision

# Logfile created on Fri Dec 16 12:20:42 +0400 2011

Processing WelcomeController#index (for 10.4.1.10 at 2011-12-16 12:33:32) [GET]
  Parameters: {"action"=>"index", "controller"=>"welcome"}
Rendering template within layouts/base
Rendering welcome/index

ActionView::TemplateError (No route matches {:controller=>"rb_all_projects", :action=>"server_variables"}) on line #20 of app/views/layouts/base.html.erb:
17:       body {behavior: url(<%= stylesheet_path "csshover.htc" %>);}
18:     </style>
19: <![endif]-->
20: <%= call_hook :view_layouts_base_html_head %>
21: <!-- page specific tags -->
22: <%= yield :header_tags -%>
23: </head>

    lib/redmine/hook.rb:63:in `send'
    lib/redmine/hook.rb:63:in `call_hook'
    lib/redmine/hook.rb:63:in `each'
    lib/redmine/hook.rb:63:in `call_hook'
    lib/redmine/hook.rb:60:in `tap'
    lib/redmine/hook.rb:60:in `call_hook'
    lib/redmine/hook.rb:144:in `call_hook'
    app/views/layouts/base.html.erb:20
    passenger (3.0.8) lib/phusion_passenger/rack/request_handler.rb:96:in `process_request'
    passenger (3.0.8) lib/phusion_passenger/abstract_request_handler.rb:513:in `accept_and_process_next_request'
    passenger (3.0.8) lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
    passenger (3.0.8) lib/phusion_passenger/classic_rails/application_spawner.rb:321:in `start_request_handler'
    passenger (3.0.8) lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `send'
    passenger (3.0.8) lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `handle_spawn_application'
    passenger (3.0.8) lib/phusion_passenger/utils.rb:479:in `safe_fork'
    passenger (3.0.8) lib/phusion_passenger/classic_rails/application_spawner.rb:270:in `handle_spawn_application'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:357:in `__send__'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:180:in `start'
    passenger (3.0.8) lib/phusion_passenger/classic_rails/application_spawner.rb:149:in `start'
    passenger (3.0.8) lib/phusion_passenger/spawn_manager.rb:219:in `spawn_rails_application'
    passenger (3.0.8) lib/phusion_passenger/abstract_server_collection.rb:132:in `lookup_or_add'
    passenger (3.0.8) lib/phusion_passenger/spawn_manager.rb:214:in `spawn_rails_application'
    passenger (3.0.8) lib/phusion_passenger/abstract_server_collection.rb:82:in `synchronize'
    passenger (3.0.8) lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
    passenger (3.0.8) lib/phusion_passenger/spawn_manager.rb:213:in `spawn_rails_application'
    passenger (3.0.8) lib/phusion_passenger/spawn_manager.rb:132:in `spawn_application'
    passenger (3.0.8) lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:357:in `__send__'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
    passenger (3.0.8) lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
    passenger (3.0.8) helper-scripts/passenger-spawn-server:99

Rendering /data/tmp/trunk/public/500.html (500 Internal Server Error)


Related issues

Duplicates Redmine - Defect #9778: No route matches controller knowledgebase Closed

History

#1 Updated by Valery Komarov almost 10 years ago

About your application's environment
Ruby version 1.8.7 (amd64-freebsd8)
RubyGems version 1.8.11
Rack version 1.1.2
Rails version 2.3.14
Active Record version 2.3.14
Active Resource version 2.3.14
Action Mailer version 2.3.14
Active Support version 2.3.14
Application root /data/tmp/trunk
Environment production
Database adapter postgresql
Database schema version 20111201201315

About your Redmine plugins
Redmine Backlogs v0.7.0

#2 Updated by Etienne Massip almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Dupe of #9778, rb_all_projects is not a Redmine core controller.

Also available in: Atom PDF