Defect #999

File size is shown as "?" when browsing an Hg repository

Added by Ollivier Robert over 13 years ago. Updated over 13 years ago.

Status:ClosedStart date:2008-04-04
Priority:HighDue date:
Assignee:-% Done:

0%

Category:SCM
Target version:-
Resolution:Fixed Affected version:

Description

File size is shown as "?" when browsing an Hg repository. See http://dev.keltia.net/repositories/show/calife for an example.

redmine-hg.png - Screenshot of the repository (107 KB) Ollivier Robert, 2008-06-27 00:22

Associated revisions

Revision 1333
Added by Jean-Philippe Lang over 13 years ago

Mercurial: display working directory files sizes unless browsing a specific revision (#999).

History

#1 Updated by Jean-Philippe Lang over 13 years ago

Actually it's not a bug, there's no way to get the size of the files that are under control (hg locate only gives the file names).
If you know a way to do it, please let me know.

#2 Updated by Thomas Lecavelier over 13 years ago

Just to precise JP point: a way without having to keep up to date the whole hg repository somewhere ;)

#3 Updated by Ollivier Robert over 13 years ago

What about using "hg locate -f" to get the full paths and File::Stat.size on each one?

#4 Updated by Jean-Philippe Lang over 13 years ago

File::Stat.size won't give the file size at a given revision.

#5 Updated by Jean-Philippe Lang over 13 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Fix committed in r1333.
Files size will be displayed using File::Stat.size unless you're browsing a specific revision.

#6 Updated by Ollivier Robert over 13 years ago

It seems that some changes since the closing of the ticket have reintroduced the problem.
I can not give you access to that particular project/repository though. The weird thing is that for the repository I opened the ticket for, it still shows the sizes but not in another one created afterwards.
See the attached image for an example.

#7 Updated by Jean-Philippe Lang over 13 years ago

  • Target version deleted (0.7)

#8 Updated by Pierre Paysant-Le Roux over 13 years ago

Hi Olivier,
can you give us the differences between the working reporitory and the not one ? Are the two repositories tracked by the same instance of Redmine ? See SubmittingBugs.

For the moment, I can't reproduce the bug you described.

Note, that Redmine can discover the size (and display correct values) of a file of a Mercurial repository only if the working directory of that repository is up to date. If it's not the case, Redmine will display wrong file sizes or no size at all if the file doesn't exists in the working directory.

#9 Updated by Thomas Lecavelier over 13 years ago

  • Status changed from Reopened to Closed

No activity on that ticket for long. Reopen if needed.

Also available in: Atom PDF