disable-sprockets.patch

Go MAEDA, 2019-10-10 04:35

Download (1.47 KB)

View differences:

Gemfile
15 15
gem "i18n", "~> 1.6.0"
16 16
gem "rbpdf", "~> 1.20.0"
17 17

  
18
# TODO: Remove the following line when #32223 is fixed
19
gem "sprockets", "~> 3.7.2"
20

  
21 18
# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
22 19
gem 'tzinfo-data', platforms: [:mingw, :x64_mingw, :mswin]
23 20

  
config/application.rb
2 2

  
3 3
require File.expand_path('../boot', __FILE__)
4 4

  
5
require 'rails/all'
5
require "rails"
6
# Pick the frameworks you want:
7
require "active_model/railtie"
8
require "active_job/railtie"
9
require "active_record/railtie"
10
require "active_storage/engine"
11
require "action_controller/railtie"
12
require "action_mailer/railtie"
13
require "action_view/railtie"
14
require "action_cable/engine"
15
# require "sprockets/railtie"
16
require "rails/test_unit/railtie"
6 17

  
7 18
Bundler.require(*Rails.groups)
8 19

  
......
40 51
    # Configure sensitive parameters which will be filtered from the log file.
41 52
    config.filter_parameters += [:password]
42 53

  
43
    # Enable the asset pipeline
44
    config.assets.enabled = false
45

  
46
    # Version of your assets, change this if you want to expire all your assets
47
    config.assets.version = '1.0'
48

  
49 54
    config.action_mailer.perform_deliveries = false
50 55

  
51 56
    # Do not include all helpers