Delete a member of a project?

Added by Nicolas QUETGLAS about 7 years ago

Hi,

I'm a new user of Redmine.
My environnment is:
Redmine 2.3.3 stable
Ruby version 1.9.3
Rails version 3.2.13
Redmine_banner 0.0.9
Sql Server 2008 R2
IIS 7

My issue is that I can't delete a member of a project.
I can modify/add a member but I can't delete a member. I don't have an error message. And I have nothing in logs.

Plz help me.

Best Regards
NicolasQ

Replies (11)

RE: Delete a member of a project? - Added by Jan Niggemann (redmine.org team member) about 7 years ago

Are you the administrator of your redmine instance?

RE: Delete a member of a project? - Added by Nicolas QUETGLAS about 7 years ago

Yes, I am (login: admin).

RE: Delete a member of a project? - Added by Pavel Potcheptsov about 7 years ago

the only case I can imagine it's user included in group and this group added to project. this is why button "delete user" absent.
if I'm wrong, please provide screenshot.

RE: Delete a member of a project? - Added by Nicolas QUETGLAS about 7 years ago

Thank you for your answer.

I add a user in a group. And I add this group in my project but I have again the issue.
Please see the attachment.

Best Regards
NicolasQ

RE: Delete a member of a project? - Added by Pavel Potcheptsov about 7 years ago

Understood, so this is not user/group management issue, but some deeper.
Did you try to increase log level verbosity?
I'm not familiar with MS IIS, but does he have access/error log for your redmine instance?

RE: Delete a member of a project? - Added by Nicolas QUETGLAS about 7 years ago

How can I increase the log level verobisty of Redmine?

Could you say to me if I have every needed gems for Redmine (see attachment)?

Thank you

Best Regards
NicolasQ

gemlist.jpg (71.8 KB)

RE: Delete a member of a project? - Added by Nicolas QUETGLAS about 7 years ago

Hi,

IIS log when I trigger a deletion:

2013-11-04 12:38:21 127.0.0.1  DELETE /memberships/100 - 8080 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.0;+WOW64;+Trident/4.0;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E) 405 0 0 2

There isn't log for Redmine when I trigger a deletion. On the other side, when I trigger a modification or an addition, I have this:

Started PUT "/memberships/100" for 127.0.0.1  at 2013-11-04 13:42:34 +0100
Processing by MembersController#update as JS
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"sxZOR134lUkNT1CqPSnmtlpSJ5Ui1Qv9NvnUsBr26ps=", "membership"=>{"role_ids"=>["3", "4", ""]}, "commit"=>"Changer", "id"=>"100"}
  Current user: admin (id=1)
  Rendered projects/settings/_members.html.erb (36.0ms)
  Rendered members/update.js.erb (38.0ms)
Completed 200 OK in 133ms (Views: 99.0ms | ActiveRecord: 20.0ms)
Started POST "/projects/master-poste-v13-12/memberships" for 127.0.0.1  at 2013-11-04 13:42:51 +0100
Processing by MembersController#create as JS
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"sxZOR134lUkNT1CqPSnmtlpSJ5Ui1Qv9NvnUsBr26ps=", "principal_search"=>"", "membership"=>{"user_ids"=>["42"], "role_ids"=>["3"]}, "commit"=>"Ajouter", "project_id"=>"master-poste-v13-12"}
  Current user: admin (id=1)
  Rendered projects/settings/_members.html.erb (40.0ms)
  Rendered members/create.js.erb (46.0ms)
Completed 200 OK in 71ms (Views: 33.0ms | ActiveRecord: 21.0ms)

I will have this

Started DELETE "/memberships/101" for 127.0.0.1 at 2013-11-04 13:46:36 +0100
Processing by MembersController#destroy as JS
  Parameters: {"id"=>"101"}
  Current user: admin (id=1)
  Rendered projects/settings/_members.html.erb (532.0ms)
  Rendered members/destroy.js.erb (544.0ms)
Completed 200 OK in 1012ms (Views: 132.0ms | ActiveRecord: 851.0ms)

but unfortunately I have nothing in Redmine log.

Best Regards
NicolasQ

RE: Delete a member of a project? - Added by Pavel Potcheptsov about 7 years ago

http://www.redmine.org/boards/2/topics/25236
Set it to config.logger.level = Logger::debug.
What is your ruby server? Does ISS serving redmine directly?

RE: Delete a member of a project? - Added by Nicolas QUETGLAS about 7 years ago

Yeahhhhhhh,

I have found the solution. In fact, in Chrome log, I had "405 Method Not allowed" error and the solution is:
http://nikhilthaker86.wordpress.com/2010/03/27/issue-hosting-restful-services-on-iis-7/

Thank you for your help.

Best Regards
NicolasQ

RE: Delete a member of a project? - Added by Pavel Potcheptsov about 7 years ago

So you removed Web-Dav option from IIS and now all works as expected?
Glad to hear this.

(1-11/11)