Requires RubyGems >= 0.9.4

Added by Laurent l over 11 years ago


Trying to update Redmine ( 0.7.4 to 0.8.4) and when I restart lighttpd I get this:

Starting web server: lighttpd Rails requires RubyGems >= 0.9.4 (you have 0.9.0). Please `gem update --system` and try again.
(mod_fastcgi.c.1022) the fastcgi-backend /usr/bin/ruby /opt/redmine/public/dispatch.fcgi failed to start:
(mod_fastcgi.c.1026) child exited with status 1 /usr/bin/ruby /opt/redmine/public/dispatch.fcgi
(mod_fastcgi.c.1029) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
(mod_fastcgi.c.1034) If this is PHP on Gentoo add fastcgi to the USE flags
(mod_fastcgi.c.1330) [ERROR]: spawning fcgi failed.
(server.c.862) Configuration of plugins failed. Going down.

debian etch
lighttpd 1.4.13
ruby 1.8.6
rack 1.0.0
rails 2.1.2
rake 0.8.7
rubygems 1.3.5

any kind of idea ?

Replies (3)

RE: Requires RubyGems >= 0.9.4 - Added by Uwe Koloska over 11 years ago

Are you sure, the ruby that is started from your webserver sees the same gems than you? I use apche with modrails (passenger) and ruby_enterprise, so the ruby apache is another one than the system ruby.

Try a simple

gem list

and then use the gem that is located alongside the ruby your webserver uses like for me

/opt/ruby-enterprise/bin/gem list

Hope this helps

RE: Requires RubyGems >= 0.9.4 - Added by Laurent l over 11 years ago

Redmine 0.7 works fine (with lighttpd).
But when I try to run the server with Redmine 0.8.4 lighttpd crash.

gem list :

actionmailer (2.3.3, 2.2.2, 2.1.2)
actionpack (2.3.3, 2.2.2, 2.1.2)
activerecord (2.3.3, 2.2.2, 2.1.2)
activeresource (2.3.3, 2.2.2, 2.1.2)
activesupport (2.3.3, 2.2.2, 2.1.2)
rack (1.0.0)
rails (2.1.2)
rake (0.8.7)
rubygems-update (1.3.5)

RE: Requires RubyGems >= 0.9.4 - Added by Berin Loritsch over 11 years ago

Did you perform the gem system update? I know there are some things that changed in the core of Rails that makes it more finicky how you integrate with MySQL. To the point even where you can't use MySQL on Windows boxes (requires a recompile, which is not an option with Windows boxes). There may be some other weirdness going on.