After Redmine upgrade 0.8.7 -> 0.9.4: TemplateError

Added by Carsten Buchenau about 12 years ago

Hi there,

After upgrading Redmine from 0.8.7 to 0.9.4 and migration of DB and plugins, I still get:

ActionView::TemplateError (There is no rule called 'default' in the en rules.) on line #6 of app/views/news/_news.rhtml:
3: <%= "(#{l(:label_x_comments, :count => news.comments_count)})" if news.comments_count > 0 >
4: <br />
5: <
unless news.summary.blank? ><span class="summary"><=h news.summary ></span><br />< end >
6: <span class="author"><
= authoring news.created_on, news.author %></span></p>

I applied the following workaround:

app/helpers$ diff application_helper.rb.orig application_helper.rb
273c273,274
< text = distance_of_time_in_words(Time.now, time)
---

#text = distance_of_time_in_words(Time.now, time)
text = 'some time'

Obviously, the "distance_of_time_in_words(Time.now, time)" causes my problem.

Same issue now when going into "My account" settings:

ActionView::TemplateError (There is no rule called 'default' in the en rules.) on line #11 of app/views/my/_sidebar.rhtml:
8:
9: <p>
10: <% if @user.rss_token >
11: # <
= l(:label_feeds_access_key_created_on, distance_of_time_in_words(Time.now, @user.rss_token.created_on)) >
12: <
= l(:label_feeds_access_key_created_on, 'some time ago') >
13: <
else >
14: <
= l(:label_missing_feeds_access_key) %>

Did the same work-around, which helps, but still not fixes the original problem with function:

distance_of_time_in_words(Time.now, time)

Any help welcome... thx!
carsten

----- Redmine Installation info -----

Linux SupportServer 2.6.28-15-server #52-Ubuntu SMP Wed Sep 9 11:34:09 UTC 2009 x86_64 GNU/Linux

Server Version: Apache/2.2.11 (Ubuntu) DAV/2 Phusion_Passenger/2.2.14 PHP/
5.2.6-3ubuntu4.5 with Suhosin-Patch mod_ssl/2.2.11 OpenSSL/0.9.8g
Server Built: Mar 9 2010 22:04:38

  1. dpkg -l|grep mysql
    ii libdbd-mysql-perl 4.008-1 A Perl5 database interface to the MySQL data
    ii libmysqlclient15off 5.1.30really5.0.75-0ubuntu10.5 MySQL database client library
    ii libmysqlclient16 5.1.31-1ubuntu2 MySQL database client library
    ii libmysqlclient16-dev 5.1.31-1ubuntu2 MySQL database development files
    ii mysql-client-5.0 5.1.30really5.0.75-0ubuntu10.5 MySQL database client binaries
    ii mysql-common 5.1.30really5.0.75-0ubuntu10.5 MySQL database common files
    ii mysql-server 5.1.30really5.0.75-0ubuntu10.5 MySQL database server (metapackage depending
    ii mysql-server-5.0 5.1.30really5.0.75-0ubuntu10.5 MySQL database server binaries
    ii mysql-server-core-5.0 5.1.30really5.0.75-0ubuntu10.5 MySQL database core server files
    ii php5-mysql 5.2.6.dfsg.1-3ubuntu4.5 MySQL module for php5

$ rails --version
Rails 2.3.8

$ RAILS_ENV=production script/about
/var/lib/gems/1.8/gems/rails-2.3.5/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010. Use #requirement
About your application's environment
Ruby version 1.8.7 (x86_64-linux)
RubyGems version 1.3.7
Rack version 1.0
Rails version 2.3.5
Active Record version 2.3.5
Active Resource version 2.3.5
Action Mailer version 2.3.5
Active Support version 2.3.5
Application root /opt/redmine-0.9.4
Environment production
Database adapter mysql
Database schema version 20100221100219

About your Redmine plugins
Kanban 0.1.1
Require Time Entry Comments 0.1.0
Timesheet Plugin 0.6.0
Customer plugin 0.2.0
Google Calendar Plugin 0.1.2
Redmine Wiki Issue Details plugin 0.1.0
Invoice plugin 0.0.1
Redmine Stealth plugin 0.1.0

Replies (3)

RE: After Redmine upgrade 0.8.7 -> 0.9.4: TemplateError - Added by Felix Schäfer about 12 years ago

Make sure all your plugins are up-to-date and that none of them causes the problem. The error seems to come from a not up-to-date language file missing the default time formatting string.

RE: After Redmine upgrade 0.8.7 -> 0.9.4: TemplateError - Added by Carsten Buchenau about 12 years ago

Interesting... I moved the sub-directory gloc-1.1.0/ out of vendor/plugins/, and now everything works fine...

Hope this makes sense?

Thanks for pointing me in the right direction!

carsten

RE: After Redmine upgrade 0.8.7 -> 0.9.4: TemplateError - Added by Felix Schäfer about 12 years ago

Yes, gloc has been removed with the transition to rails 2.2 in r2493 because it wasn't needed anymore. I think you might have an incomplete upgrade.

(1-3/3)