followed instructions for install on Ubuntu 10.04 w/mod_cgi, 403 forbidden error when running script

Added by Nathan Scrivener almost 10 years ago

Hi, I am new to Redmine (and server administration in general), so please forgive me if this comes across stupid. I have installed Redmine according to the instructions on [[http://www.redmine.org/wiki/1/HowTo_Install_Redmine_in_Ubuntu]], according to the mod_cgi instructions which seem to be the easiest to follow.

The script installed in the installation directory was called 'dispatch.fcgi', and not parsing when I visited the page through the browser, just displaying the contents of the script. OK, so I installed the apache mod libapache2-mod-fastcgi using apt-get. Then 'a2enmod fcgid' followed by an apache restart.

Now when I visit the Redmine folder through the web browser I get 'Forbidden You don't have permission to access /redmine/dispatch.fcgi on this server.'

I checked to ensure www-data owns all files and has correct permissions to the folder. But this doesn't seem to work. Would somebody advise how to get around this issue, if they have some ideas?

Thanks

Replies (1)

RE: followed instructions for install on Ubuntu 10.04 w/mod_cgi, 403 forbidden error when running script - Added by Tim M almost 10 years ago

I just ran into the same problem. Did you find the solution?

There appear to be a couple problems. First, the mod_cgi instructions simply don't seem to work. After wasting hours setting it up, I could not get the mod_cgi configuration to work at all.

To get Redmine running, I had to do two things:
  1. Follow the instructions for setting up Redmine in Ubuntu 10.04 using Passenger.
  2. Change the permissions of the Redmine public folder to be executable:
    $ sudo chmod a+x /usr/share/redmine/public

Now I no longer receive the 403 Forbidden error and redmine seems to be working normally.

(1-1/1)