does not create a new project

Added by Andrey Medvedev about 7 years ago

/projects/new

On the creation of the project I enter the necessary data for the project, and then click the button "Create" and then throws me to the list of projects, but a new project is not created.

What's more - when you create a project, you can not enter anything in the field, click the "create" and nothing happens - no error message fill in the required fields are not shown.

The logs nothing unusual:

Started GET "/projects/new" for 10.0.0.100 at 2013-05-20 12:48:55 +0400
Processing by ProjectsController#new as HTML
  Current user: admin (id=1)
  Rendered projects/_form.html.erb (8.0ms)
  Rendered projects/new.html.erb within layouts/base (8.7ms)
Completed 200 OK in 30ms (Views: 23.8ms | ActiveRecord: 1.7ms)
Started GET "/projects/" for 10.0.0.100 at 2013-05-20 12:48:58 +0400
Processing by ProjectsController#index as HTML
  Current user: admin (id=1)
  Rendered projects/index.html.erb within layouts/base (13.8ms)
Completed 200 OK in 36ms (Views: 28.4ms | ActiveRecord: 1.2ms)

In the demo, this error is not repeated.

Other info

Environment:
  Redmine version                          2.3.1.stable
  Ruby version                             1.9.3 (x86_64-linux)
  Rails version                            3.2.13
  Environment                              production
  Database adapter                         Mysql2
Redmine plugins:
  no plugin installed
# RAILS_ENV=production rake about
(in /home/redmine)
About your application's environment
Ruby version              1.9.3 (x86_64-linux)
RubyGems version          1.8.23
Rack version              1.4
Rails version             3.2.13
Active Record version     3.2.13
Action Pack version       3.2.13
Active Resource version   3.2.13
Action Mailer version     3.2.13
Active Support version    3.2.13
Middleware                Rack::Cache, ActionDispatch::Static, Rack::Lock, #<ActiveSupport::Cache::Strategy::LocalCache::Middleware:0x000000010b8550>, Rack::Runtime, Rack::MethodOverride, ActionDispatch::RequestId, Rails::Rack::Logger, ActionDispatch::ShowExceptions, ActionDispatch::DebugExceptions, ActionDispatch::RemoteIp, ActionDispatch::Callbacks, ActiveRecord::ConnectionAdapters::ConnectionManagement, ActiveRecord::QueryCache, ActionDispatch::Cookies, ActionDispatch::Session::CookieStore, ActionDispatch::Flash, ActionDispatch::ParamsParser, ActionDispatch::Head, Rack::ConditionalGet, Rack::ETag, ActionDispatch::BestStandardsSupport, OpenIdAuthentication
Application root          /home/redmine
Environment               production
Database adapter          mysql2
Database schema version   20130217094251

Please help to understand what is wrong.
Thanks in advance.

Replies (2)

RE: does not create a new project - Added by Jean-Baptiste Barth about 7 years ago

I only see "GET" requests in the logs. If you try to create a project, you should see a "POST" request when you submit the form.

If you can confirm you have a "GET" log at the very same moment you submit the form, then something is wrong in the form. It shouldn't happen, the form looks good at first sight (and it seems to work for me on a standard redmine install...).

If you don't see anything in the logs when you're creating the project, then something is probably wrong outside Redmine (on a firewall or reverse-proxy blocking you before the requests goes through the whole stack).

RE: does not create a new project - Added by Andrey Medvedev about 7 years ago

Thank you for your response

In fact when submitting the form in the logs no POST requests. Right after i send form only GET request fixed in the logs.
At the same time the rest of the functional Redmine works perfectly.

No problems with the firewall. Tested on several computers.
Sin on versions of server libs or of any problem in the database.

There are offers where to dig?

(1-2/2)