Upgrading Redmine, constant error

Added by Tom Girou 3 months ago

Ruby 2.6.6p146
Rails 5.2.5
Unix
MySQL 8.0.22
Probably Webrick

Hi, my problem is that I'm trying to upgrade my Redmine version. I already fixed many old plugins, but this time, I've an error that comes from Redmine files itselves, and I guess that's not supposed to happen :

Unable to autoload constant Redmine::SafeAttributes, expected /var/www/sites/tgirou/redmine-4.1.1/lib/redmine/safe_attributes.rb to define it

The folder says redmine 4.1.1 but I use the 4.2

The error is caused by the include in Issue class (issue.rb) :

include Redmine::SafeAttributes

Any insight is welcome.

Thank you

Replies (2)

RE: Upgrading Redmine, constant error - Added by Lorenzo Meneghetti 2 months ago

Hi, what does it mean "Probably Webrick"? You should know which server are you running?
In which path are your redmine files? Does your path match with the one redmine expect to load safe_attributes.rb?
Regards
Lorenzo

RE: Upgrading Redmine, constant error - Added by Tom Girou 2 months ago

It means I didn't set up the server. It's my sysadmin. The path is totally correct and the file is found at the right path.

(1-2/2)