Unable to Create or Edit Projects

Added by Jason Ang 4 months ago

Hi all,

I recently upgraded Redmine from 4.2.3-3 to 5.0.2 stable.

Everything worked well until I tried creating and editing projects which gave me an internal error which asked to view the logs. Upon viewing the logs, I found the following error messages:

F, [2022-08-22T13:52:07.490439 #416] FATAL -- : [ef2d8e55-909b-4388-8b85-8bc674914750]
[ef2d8e55-909b-4388-8b85-8bc674914750] ActionView::Template::Error (undefined method `default_issue_query_id' for #<Project:0x00000214b2b48138>
Did you mean? default_issue_query
default_issue_query=):
[ef2d8e55-909b-4388-8b85-8bc674914750] 44: <% end >
[ef2d8e55-909b-4388-8b85-8bc674914750] 45:
[ef2d8e55-909b-4388-8b85-8bc674914750] 46: <
if @project.safe_attribute?('default_issue_query_id') >
[ef2d8e55-909b-4388-8b85-8bc674914750] 47: <p><
= f.select :default_issue_query_id, project_default_issue_query_options(@project), include_blank: l(:label_none) ><em class="info"><=l 'text_allowed_queries_to_select' ></em></p>
[ef2d8e55-909b-4388-8b85-8bc674914750] 48: <
end %>
[ef2d8e55-909b-4388-8b85-8bc674914750] 49: </div>
[ef2d8e55-909b-4388-8b85-8bc674914750] 50:
[ef2d8e55-909b-4388-8b85-8bc674914750]

Has anyone faced the same issue or able to help on this, please?

Thank you!

Internal Error.PNG (8.16 KB)

Error Logs.PNG (80.4 KB)

Redmine Details.PNG (31.1 KB)

Replies (1)

RE: Unable to Create or Edit Projects - Added by Dariusz Makowski 13 days ago

I'm having the exact same problem.
Were you able to fix it ?

Ok fixed
https://www.redmine.org/projects/redmine/wiki/redmineupgrade
Step 4/5.
Execute it on redmine docker/redmine running system.

(1-1/1)