Project

General

Profile

Redmine 4.1 and 5.0 on the same server

Added by Klaus Friese 6 months ago

Hi,

We're using redmine 4.1.1.stable at the moment with ruby 2.6.5p114 and Rails 6.0.3.2.

I like to upgrade in the near future and I like to test some plugins first. I duplicated my installation (all files and database) - works fine and I like to upgrade the duplicate now to the latest release. Requirements are Rails 6.1 and ruby 2.51, 2.61, 2.7, 3.0, 3.1. I think i will upgrade to a newer ruby version, 2.6 support has endet.

Two questions: does an upgrade to Rails 6.1 and ruby 2.7, 3.0, 3.1 affect my current 4.1.1 installation?
And which ruby version is best? 2.7, 3.0 or 3.1?

Thanks for any tipps
Klaus


Replies (1)

RE: Redmine 4.1 and 5.0 on the same server - Added by C S 6 months ago

Redmine 4.1 supports at max Ruby 2.6 and Rails 5.2

See here: https://www.redmine.org/projects/redmine/wiki/RedmineInstall/315

    (1-1/1)