Can't run Redmine on Apache. Only lists the folder content

Added by Jorge Raimundo over 13 years ago

Hi all!

I'm trying to set up redmine on our server.

The box is running OpenSuse 11.1.

I've checked out the revision 2924 from Subversion.

The environment is the following:

About your application's environment
Ruby version              1.8.7 (x86_64-linux)
RubyGems version          1.3.5
Rack version              1.0
Rails version             2.3.4
Active Record version     2.3.4
Active Resource version   2.3.4
Action Mailer version     2.3.4
Active Support version    2.3.4
Application root          /srv/www/htdocs/redmine
Environment               production
Database adapter          mysql
Database schema version   20091010093521

Mysql is 5.0.16.

The apache's vhost is like this:

<VirtualHost *:80>
        DocumentRoot /srv/www/redmine/public/
        ServerName redmine.mydomain.com
        ServerAdmin administrador.sistemas@mydomain.com
        CustomLog /var/log/apache2/redmine.mydomain.com.log common
        ErrorLog /var/log/apache2/redmine.mydomain.com.error_log

        <Directory /srv/www/redmine/public/>
                Options Indexes ExecCGI FollowSymLinks
                AllowOverride None
                Order allow,deny
                Allow from all
        </Directory>
</VirtualHost>

mod_cgi is enabled, it's running on a name based vhost and the document root is owned by the apache user and group.

Problem is that when I go to redmine.mydomain.com I get a list of the public folder's content instead of getting redmine's first page. Apache and vhost's logs show nothing.

Any ideas?

Best regards,
Jorge

Replies (2)

RE: Can't run Redmine on Apache. Only lists the folder content - Added by Marianne Promberger over 13 years ago

Hi

I'm sure there are alternatives, but I got Redmine running with Apache by first installing phusion-passenger: http://www.modrails.com/

Then it was a snap.

RE: Can't run Redmine on Apache. Only lists the folder content - Added by Jorge Raimundo over 13 years ago

Hello Marianne!

Thank you for your reply.

I followed your advice and it worked :)

Thanks a lot.

(1-2/2)