Issue while upgrade to new version

Added by chris sabu over 7 years ago

Hi Team

I have upgraded the redmine from version 1.3.1 to 2.2.4.For testing the installation by running WEBrick web server. I got an error like this:
LoadError (no such file to load -- gapps_openid):
activesupport (3.2.13) lib/active_support/dependencies.rb:251:in `require'
activesupport (3.2.13) lib/active_support/dependencies.rb:251:in `require'
activesupport (3.2.13) lib/active_support/dependencies.rb:236:in `load_dependency'
activesupport (3.2.13) lib/active_support/dependencies.rb:251:in `require'
plugins/google_apps/app/controllers/google_apps_controller.rb:1
activesupport (3.2.13) lib/active_support/dependencies.rb:251:in `require'
activesupport (3.2.13) lib/active_support/dependencies.rb:251:in `require'
activesupport (3.2.13) lib/active_support/dependencies.rb:236:in `load_dependency'
activesupport (3.2.13) lib/active_support/dependencies.rb:251:in `require'
activesupport (3.2.13) lib/active_support/dependencies.rb:359:in `require_or_load'
activesupport (3.2.13) lib/active_support/dependencies.rb:502:in `load_missing_constant'
activesupport (3.2.13) lib/active_support/dependencies.rb:192:in `const_missing'
activesupport (3.2.13) lib/active_support/dependencies.rb:190:in `each'
activesupport (3.2.13) lib/active_support/dependencies.rb:190:in `const_missing'
activesupport (3.2.13) lib/active_support/inflector/methods.rb:219:in `constantize'
activesupport (3.2.13) lib/active_support/inflector/methods.rb:218:in `each'
activesupport (3.2.13) lib/active_support/inflector/methods.rb:218:in `constantize'
activesupport (3.2.13) lib/active_support/dependencies.rb:554:in `get'
actionpack (3.2.13) lib/action_dispatch/routing/route_set.rb:69:in `controller_reference'
actionpack (3.2.13) lib/action_dispatch/routing/route_set.rb:54:in `controller'
actionpack (3.2.13) lib/action_dispatch/routing/route_set.rb:32:in `call'
journey (1.0.4) lib/journey/router.rb:68:in `call'
journey (1.0.4) lib/journey/router.rb:56:in `each'
journey (1.0.4) lib/journey/router.rb:56:in `call'
actionpack (3.2.13) lib/action_dispatch/routing/route_set.rb:612:in `call'
rack-openid (1.3.1) lib/rack/openid.rb:98:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'
rack (1.4.5) lib/rack/etag.rb:23:in `call'
rack (1.4.5) lib/rack/conditionalget.rb:25:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/head.rb:14:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/params_parser.rb:21:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/flash.rb:242:in `call'
rack (1.4.5) lib/rack/session/abstract/id.rb:210:in `context'
rack (1.4.5) lib/rack/session/abstract/id.rb:205:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/cookies.rb:341:in `call'
activerecord (3.2.13) lib/active_record/query_cache.rb:64:in `call'
activerecord (3.2.13) lib/active_record/connection_adapters/abstract/connection_pool.rb:479:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/callbacks.rb:28:in `call'
activesupport (3.2.13) lib/active_support/callbacks.rb:405:in `_run__924542388__call__4__callbacks'
activesupport (3.2.13) lib/active_support/callbacks.rb:405:in `send'
activesupport (3.2.13) lib/active_support/callbacks.rb:405:in `__run_callback'
activesupport (3.2.13) lib/active_support/callbacks.rb:385:in `_run_call_callbacks'
activesupport (3.2.13) lib/active_support/callbacks.rb:81:in `send'
activesupport (3.2.13) lib/active_support/callbacks.rb:81:in `run_callbacks'
actionpack (3.2.13) lib/action_dispatch/middleware/callbacks.rb:27:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/remote_ip.rb:31:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
railties (3.2.13) lib/rails/rack/logger.rb:32:in `call_app'
railties (3.2.13) lib/rails/rack/logger.rb:16:in `call'
activesupport (3.2.13) lib/active_support/tagged_logging.rb:22:in `tagged'
railties (3.2.13) lib/rails/rack/logger.rb:16:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/request_id.rb:22:in `call'
rack (1.4.5) lib/rack/methodoverride.rb:21:in `call'
rack (1.4.5) lib/rack/runtime.rb:17:in `call'
activesupport (3.2.13) lib/active_support/cache/strategy/local_cache.rb:72:in `call'
rack (1.4.5) lib/rack/lock.rb:15:in `call'
actionpack (3.2.13) lib/action_dispatch/middleware/static.rb:63:in `call'
rack-cache (1.2) lib/rack/cache/context.rb:136:in `forward'
rack-cache (1.2) lib/rack/cache/context.rb:245:in `fetch'
rack-cache (1.2) lib/rack/cache/context.rb:185:in `lookup'
rack-cache (1.2) lib/rack/cache/context.rb:66:in `call!'
rack-cache (1.2) lib/rack/cache/context.rb:51:in `call'
railties (3.2.13) lib/rails/engine.rb:479:in `call'
railties (3.2.13) lib/rails/application.rb:223:in `call'
rack (1.4.5) lib/rack/content_length.rb:14:in `call'
railties (3.2.13) lib/rails/rack/log_tailer.rb:17:in `call'
rack (1.4.5) lib/rack/handler/webrick.rb:59:in `service'
/usr/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
/usr/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
/usr/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
/usr/lib/ruby/1.8/webrick/server.rb:95:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `each'
/usr/lib/ruby/1.8/webrick/server.rb:92:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:23:in `start'
/usr/lib/ruby/1.8/webrick/server.rb:82:in `start'
rack (1.4.5) lib/rack/handler/webrick.rb:13:in `run'
rack (1.4.5) lib/rack/server.rb:268:in `start'
railties (3.2.13) lib/rails/commands/server.rb:70:in `start'
railties (3.2.13) lib/rails/commands.rb:55
railties (3.2.13) lib/rails/commands.rb:50:in `tap'
railties (3.2.13) lib/rails/commands.rb:50
script/rails:6:in `require'
script/rails:6
Here is the list of plugin that i am using in my old redmine:
1)Google Apps plugin

Please help me.My upgrade is stopped due to this issue

Thanks
chris

Replies (2)

RE: Issue while upgrade to new version - Added by chris sabu over 7 years ago

Any one please help me

RE: Issue while upgrade to new version - Added by Martin Dubé over 7 years ago

chris sabu wrote:

Here is the list of plugin that i am using in my old redmine:
1)Google Apps plugin

Please help me.My upgrade is stopped due to this issue

Thanks
chris

The Google Apps plugin isn't listed as being compatible with redmine 2.x:
http://www.redmine.org/plugins/google_apps

Try removing this plugin.

(1-2/2)