Defect #10052

Project's settings - 500 Internal Server Error

Added by Robson Peixoto over 10 years ago. Updated over 6 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Project settings
Target version:-
Resolution:Cant reproduce Affected version:1.3.0

Description

Processing ProjectsController#settings (for 172.20.10.68 at 2012-01-25 00:47:22) [GET]
Parameters: {"action"=>"settings", "id"=>"p5", "controller"=>"projects"}
Rendering template within layouts/base
Rendering projects/settings

ActionView::TemplateError (undefined method `<=>' for nil:NilClass) on line #3 of app/views/projects/settings/_members.html.erb:
1: <%= error_messages_for 'member' >
2: <
roles = Role.find_all_givable
3: members = @project.member_principals.find(:all, :include => [:roles, :principal]).sort >
4:
5: <div class="splitcontentleft">
6: <
if members.any? %>

app/models/member.rb:53:in `<=>'
app/views/projects/settings/_members.html.erb:3:in `sort'
app/views/projects/settings/_members.html.erb:3
app/views/common/_tabs.html.erb:24
app/views/common/_tabs.html.erb:23:in `each'
app/views/common/_tabs.html.erb:23
app/helpers/application_helper.rb:222:in `render_tabs'
app/views/projects/settings.html.erb:3
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/rack/request_handler.rb:96:in `process_request'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_request_handler.rb:513:in `accept_and_process_next_request'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/classic_rails/application_spawner.rb:321:in `start_request_handler'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `send'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `handle_spawn_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/utils.rb:479:in `safe_fork'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/classic_rails/application_spawner.rb:270:in `handle_spawn_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:357:in `__send__'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:180:in `start'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/classic_rails/application_spawner.rb:149:in `start'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/spawn_manager.rb:219:in `spawn_rails_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server_collection.rb:132:in `lookup_or_add'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/spawn_manager.rb:214:in `spawn_rails_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server_collection.rb:82:in `synchronize'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/spawn_manager.rb:213:in `spawn_rails_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/spawn_manager.rb:132:in `spawn_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:357:in `__send__'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'
/opt/ree/lib/ruby/gems/1.8/gems/passenger-3.0.11/helper-scripts/passenger-spawn-server:99

Rendering /var/convergence/redmine/public/500.html (500 Internal Server Error)


Related issues

Duplicated by Redmine - Defect #10090: Project's settings - 500 Internal Server Error Closed

History

#1 Updated by Go MAEDA over 6 years ago

  • Duplicated by Defect #10090: Project's settings - 500 Internal Server Error added

#2 Updated by Go MAEDA over 6 years ago

  • Status changed from New to Closed
  • Resolution set to Cant reproduce

Closing this issue because Redmine 1.3.0 is too old (released in 2011) and not maintained.
Please create a new issue if the problem persists in the latest version of Redmine.

Also available in: Atom PDF