Defect #10755

Why I got "Email has already been taken" message when creating new user?

Added by Xun Mao over 9 years ago. Updated over 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Administration
Target version:-
Resolution:Cant reproduce Affected version:

Description

I'm trying to create a new user, with my current email address. Don't know
why, I got the message "Email has already been taken". I have checked, actually there is only one user "admin" available. And it's email address is
"".

Does anyone know, how can I solve this problem?

Thanks in advance!

Xun

History

#1 Updated by Jean-Philippe Lang over 9 years ago

  • Priority changed from High to Normal
  • Resolution set to Cant reproduce

#2 Updated by mc0e . over 6 years ago

+1. I had the same issue, but it was confusion on my part. Not a defect, but perhaps the situation could be better signposted.

I had created a user successfully already, but wasn't seeing it under 'users' when logged in as the admin, because it hadn't been approved. I didn't know to look under a separate list of "registered" users, and that naming still doesn't strike me as particularly intuitive.

How about when an admin user goes to http://redmine.together4change.org/users they get a text notification and link saying something like "There are new users awaiting admin approval".

#3 Updated by Umesh Rajani over 5 years ago

We are getting exactly same error while updating User detail using redmine Java REST API.

com.taskadapter.redmineapi.RedmineProcessingException: Login has already been taken
java.lang.Exception: com.taskadapter.redmineapi.RedmineProcessingException: Login has already been taken
  • Redmine version 2.6.0.stable
  • Ruby version 1.9.3-p484 (2013-11-22) [x86_64-linux]
  • Rails version 3.2.19

#4 Updated by Go MAEDA over 2 years ago

  • Status changed from New to Closed

Please reopen this issue if you still experience the problem.

Also available in: Atom PDF