Project

General

Profile

Actions

Defect #11325

closed

Unified diff link broken on specific file/revision diff view

Added by Etienne Massip over 11 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
SCM
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

Clicking on the "Unified diff" linkt at the bottom of a diff page of a specific file for a specific revision doesn't work anymore.

For a SVN revision, it simply produces a 404 error page.

The unified diff link is badly formatted; instead of adding a format query parameter, it seems that source:/tags/2.0.3/lib/redmine/views/other_formats_builder.rb#L26 format value is now appended at the end of the URI like a file extension.

Actions #1

Updated by Jean-Philippe Lang over 11 years ago

  • Subject changed from Unified diff returns a HTML 404 error page to Unified diff link broken on specific file/revision diff view
  • Status changed from Confirmed to Resolved
  • Resolution set to Fixed

Fixed in r9909.

Actions #2

Updated by Jean-Philippe Lang over 11 years ago

  • Target version changed from Candidate for next minor release to 2.0.4
Actions #3

Updated by Jean-Philippe Lang over 11 years ago

  • Status changed from Resolved to Closed

Merged.

Actions #4

Updated by Anthony Mallet about 5 years ago

Hi,

This seems broken again with 4.0.1 :)

Actions #5

Updated by Go MAEDA about 5 years ago

Anthony Mallet wrote:

This seems broken again with 4.0.1 :)

Please open a new issue and describe the details. Since this issue is closed and the fix was already released, we cannot discuss here.

Actions

Also available in: Atom PDF