Project

General

Profile

Actions

Feature #11993

closed

Reload plugin assets on every request in development mode

Added by John Yani over 11 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Plugin API
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

I develop a plugin that requires Ajax.
I've put my scripts to plugin/assets folder.
It's very inconvenient to develop a plugin since I have to reload redmine each time I change my scripts.
It would be great to reload plugin assets on each request.


Related issues

Is duplicate of Redmine - Patch #31457: Add support for reloading plugin assets automatically in development modeClosedGo MAEDA

Actions
Actions #1

Updated by Jean-Philippe Lang over 11 years ago

As a workaround, you can call Redmine::Plugin.mirror_assets(:your_plugin) from your plugin on each request when running in development environment.

Actions #2

Updated by Jean-Baptiste Barth over 11 years ago

Other idea as a workaround, you can symlink public/plugin_assets/<your plugin> to plugins/<your plugin>/assets if you're on Linux, any *nix or MacOS.. I don't know if there's something similar on Windows.

Actions #3

Updated by Jongwook Choi over 10 years ago

We need this.

Actions #4

Updated by Go MAEDA almost 4 years ago

  • Category set to Plugin API
  • Status changed from New to Closed
  • Resolution set to Duplicate

The feature has been implemented in Redmine 4.1.0 (#31457).

Actions #5

Updated by Go MAEDA almost 4 years ago

  • Is duplicate of Patch #31457: Add support for reloading plugin assets automatically in development mode added
Actions

Also available in: Atom PDF