Defect #12720

TLS configuration documentation for Rails 3

Added by Rodrigo Macedo over 7 years ago. Updated over 1 year ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:


Category:Email notifications
Target version:-
Resolution:Invalid Affected version:2.2.0


When installing 2.2-stable the smtp configuration settings for TLS encryption is somewhat broken, as notified by [1].

If a smtp server is configured with both "tls: true" and "enable_starttls_auto: true", this error occurs when trying to send mail:

An error occurred while sending mail (SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol)

This type of configuration is also the suggested method for configuring gmail in the redmine documentation [2].

As a workaround found by [1], you can remove the "tls: true" part of the configuration, while leaving in "enable_starttls_auto: true". I can also confirm that this workaround works for me, to make gmail & redmine working.


Check informations my enviroment
The problem occurs in my enviroment when start Redmine as Windows Service, when I run Redmine with the follow command "thin -c D:/WorkRuby/work/2.2-stable start -p 3001" the Redmine working, but when I run Redmine as Windows Service with the same command, it doesn't work.

My OS is Windows XP
Redmine version 2.2.0.stable
Ruby version 1.9.2 (i386-mingw32)
Rails version 3.2.9
Environment development
Database adapter Mysql2
Redmine plugins:
no plugin installed

configuration.yml Magnifier (7.14 KB) Rodrigo Macedo, 2013-01-03 14:16


#1 Updated by Marius BALTEANU over 1 year ago

  • Status changed from New to Closed
  • Resolution set to Invalid

Rails 3 is no longer supported.

Also available in: Atom PDF