Project

General

Profile

Actions

Defect #14276

closed

Limit users than can reference and fix issues in commit messages

Added by Benoit Duffez over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
SCM
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

Currently, all commit messages are analyzed and processed to update issues.

This can be an issue if one merges an existing git repository into the project's, if that said repository has commit messages that contain "fix issue #xyz" for example.

An easy way to fix this would be to actually edit the referenced/fixed issues from commit messages only if the committer is mapped to a Redmine user.

Hence, commit messages containing "fixes #xyz" from another repository wouldn't mess with the current project, because they are not linked to a Redmine user.


Related issues

Is duplicate of Redmine - Defect #13762: SCM auto status change bypassses roles and permissionsConfirmed

Actions
Actions #1

Updated by Toshi MARUYAMA over 10 years ago

  • Category set to SCM
Actions #2

Updated by Toshi MARUYAMA over 10 years ago

  • Related to Defect #13762: SCM auto status change bypassses roles and permissions added
Actions #3

Updated by Benoit Duffez over 10 years ago

Actually the proposed behavior in #13762 perfectly matches what's described in this issue:

My solution is to add three configuratoin options to the repos.

[] Allow altering of tickets through commit messages
[] Allow system wide altering of tickets through commit messages
[] Allow Non-mapped users in the repo to alter tickets through commit messages

I don't (apparently) have rights to mark this one as a dupe of #13762

Actions #4

Updated by Toshi MARUYAMA over 10 years ago

  • Related to deleted (Defect #13762: SCM auto status change bypassses roles and permissions)
Actions #5

Updated by Toshi MARUYAMA over 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Thank you for your feedback.

Actions #6

Updated by Toshi MARUYAMA over 10 years ago

  • Is duplicate of Defect #13762: SCM auto status change bypassses roles and permissions added
Actions

Also available in: Atom PDF