Project

General

Profile

Actions

Feature #14470

closed

Standard implementation of redmine 'stealth mode'

Added by Riccardo Rocca over 10 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Email notifications
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Possibility (at user profile level) to toggle on/off sending email, like in plugin redmine_stealth (which actually doesn't work in e.g. 2.3.0) version


Related issues

Is duplicate of Redmine - Feature #9068: New button : "Submit modification without notification"New2011-08-16

Actions
Actions #1

Updated by Francesco V over 10 years ago

-1

Actions #2

Updated by Riccardo Rocca over 10 years ago

Just upgraded Redmine to 2.3.3 and the plugin redmine_stealth 'magically' works again!
Anyway I think this feature should be incorporated in Redmine project because it's really useful!

Actions #3

Updated by Radosław Lejek about 10 years ago

Actually it doesn't work again in redmine 2.4.2 with error on start:

plugins/redmine_stealth/init.rb:24:in `join': can't convert nil into String (TypeError)

Shame, it's the best plugin there is.

Actions #4

Updated by Maik Lindner about 10 years ago

+1

same here, plugin doesn't work with 2.4.2

can't convert nil into String
/usr/share/redmine/plugins/redmine_stealth/init.rb:24:in `join'

Actions #5

Updated by Maik Lindner about 10 years ago

redmine_stealth plugin will work with 2.4.2 if you edit init.rb (from line 23):

#  plugin_locale_glob = respond_to?(:directory) ?
#    File.join(directory, 'config', 'locales', '*.yml') :
    File.join(Rails.root, 'vendor', 'plugins',
              'redmine_stealth', 'config', 'locales', '*.yml')

#  ::I18n.load_path += Dir.glob(plugin_locale_glob)
Actions #6

Updated by Carsten Buchenau over 8 years ago

That modification works with Redmine 2.6.5 as well.

Saved my day - thanks Maik!

Actions #7

Updated by Toshi MARUYAMA almost 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Duplicate of #9068.

Actions #8

Updated by Toshi MARUYAMA almost 7 years ago

  • Is duplicate of Feature #9068: New button : "Submit modification without notification" added
Actions

Also available in: Atom PDF