Defect #14753

Remember issue filter for each project

Added by Tyler P almost 8 years ago. Updated 19 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Fixed Affected version:

Description

When I switch projects, redmine forgets my issue filters for the last project. It would be great if it remembered the filter for each project. Maybe by creating a different cookie for each project?

Reproduce:
1. Apply a filter to the issues in a project.
2. Open a new tab in the browser and apply a filter in a different project.
3. Click the issues redmine tab in the first project.

Expected:
The filter is still there.

Actual:
The filter returns to the default, and must be selected again.

Notes:
Creating custom queries is a possible workaround, but still requires an extra page load because redmine loads the default filter, then, after you click the link to the custom query, loads again.


Related issues

Related to Redmine - Feature #7360: Issue Custom Query: Default Query Closed 2011-01-18

History

#1 Updated by Go MAEDA almost 4 years ago

  • Related to Feature #7360: Issue Custom Query: Default Query added

#2 Updated by Marcus Fleuti over 2 years ago

I hope that this feature will be release soon too. It's very annoying. It should be possible to define a global default filter and then save a dedicated filter per project.

#3 Updated by Taine Woo almost 2 years ago

+1
i think it's better to save the changes to filters/columns/groupby to session cookie or something related.

#4 Updated by Go MAEDA 19 days ago

  • Category set to Issues
  • Status changed from New to Closed
  • Resolution set to Fixed

Redmine 5.0.0 will allow you to set a default query for each project (#7360).

Save the filter as a custom query, and then set the query as the default query for the project.

Also available in: Atom PDF