Project

General

Profile

Actions

Defect #14835

closed

Request: Don't notify users of their own changes to issues

Added by Andrew Pennebaker about 10 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Email notifications
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

When I change an issue in Redmine, I don't need an email telling me what I just did. Could we change the default behavior to skip notifications when the user is the initiator?


Related issues

Is duplicate of Redmine - Feature #14574: "I don't want to be notified of changes that I make myself" as Default for all UserClosedJean-Philippe Lang

Actions
Actions #1

Updated by Thomas Godard about 10 years ago

Just go to your account page and check the box : I don't want to be notified of changes that I make myself

Putting this by default might not be wanted by everybody ...

What could be done could be in the settings add a checkbox under the "Default notification option" named "I want default notification for the changes I do" which would change the default behavior for any new account and it would be a feature request.

Actions #2

Updated by Jan Niggemann (redmine.org team member) about 10 years ago

  • Status changed from New to Closed

Exactly like that, go to your account page and check the box : I don't want to be notified of changes that I make myself

Actions #3

Updated by Ismael BarrosĀ² about 9 years ago

I'm sorry for reviving the dead, but I don't think this issue should've been closed. This issue discusses the default value for this setting, and the fact that it can be manually changed is assumed, and actually unrelated.

I think not being notified by the changes I made myself is a much saner default. I've introduced many novice users to Redmine, and most of them complaint that they receive too many superfluous emails from Redmine until I teach them to change this setting. It's just bad user experience.

Actions #4

Updated by Go MAEDA almost 8 years ago

  • Is duplicate of Feature #14574: "I don't want to be notified of changes that I make myself" as Default for all User added
Actions #5

Updated by Go MAEDA almost 8 years ago

  • Resolution set to Duplicate
Actions

Also available in: Atom PDF