Defect #19925

Arabic settings page - Icons are not aligned correctly

Added by Ouss Orange over 6 years ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:I18n
Target version:-
Resolution:Cant reproduce Affected version:3.0.3

Description

Icons in the Setting Page in the Arabic interface are not aligned correctly they appear behind text. It looks like the it is a .css file issue.

Screenshot from 2015-05-22 23_45_21.png (48.1 KB) Ouss Orange, 2015-05-22 23:45

arabic-admin.png (70.3 KB) Go MAEDA, 2021-08-10 14:53

History

#1 Updated by Ouss Orange over 6 years ago

It could be fixed if the horizontal position of the background-image is set to 100% instead of 0% in the Arabic version of the application.css file. This would work also for Hebrew.

As demonstrated here:
media="all"
#admin-menu a {
background-position: 0% 40%;
background-position: 100% 40%;
background-repeat: no-repeat;
padding-left: 20px;
padding-top: 2px;
padding-bottom: 3px;
}

#2 Updated by Toshi MARUYAMA over 6 years ago

rtl.css should be changed instead of application.css.
source:tags/3.0.3/public/stylesheets/rtl.css#L18

#3 Updated by Go MAEDA 5 months ago

  • File arabic-admin.png added
  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Cant reproduce

No problem found in Redmine 4.2.2.

Also available in: Atom PDF