Feature #19971

Redmine 3.0 - Need to authorize users using client-side certificates

Added by Tony Giordano over 7 years ago.

Status:NewStart date:
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:

Description

We are operating in an environment which requires the use of client-side certificates for users to authenticate (LDAP over SSL). There were two plugins previously created that do not work with Redmine 3.x or do not have the required functionality. I am attempting to support this for a major corporation in a DevOps environment.

Environment:
Redmine version 3.0.1.stable
Ruby version 2.2.0-p0 (2014-12-25) [x86_64-linux]
Rails version 4.2.0
Environment production
Database adapter Mysql2
Apache Server version: Apache/2.2.15 (Unix)

Also available in: Atom PDF